VOP_LEASE man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VOP_LEASE(9)		 BSD Kernel Developer's Manual		  VOP_LEASE(9)

NAME
     VOP_LEASE — validate a vnode for a particular set of credentials and
     operation type

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>

     int
     VOP_LEASE(struct vnode *vp, struct proc *p, struct ucred *cred,
	 int type);

DESCRIPTION
     This entry point is currently not implemented.  I believe the idea is to
     validate a vnode for a particular set of user credentials and operation
     type.  The two operation types supported are LEASE_READ and LEASE_WRITE.
     The function currently always returns 0.

LOCKS
     The vnode must be exclusively locked on entry, and should remain exclu‐
     sively locked on return.

RETURN VALUES
     If successful, zero is returned.  Otherwise, well... zero is returned
     too.

SEE ALSO
     VOP_READ(9), VOP_WRITE(9)

AUTHORS
     This man page was written by Matt Dillon.

BSD			      September 24, 1999			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net