VOP_GETEXTATTR man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VOP_GETEXTATTR(9)	 BSD Kernel Developer's Manual	     VOP_GETEXTATTR(9)

NAME
     VOP_GETEXTATTR — retrieve named extended attribute from a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>
     #include <sys/extattr.h>

     int
     VOP_GETEXTATTR(struct vnode *vp, char *name, struct uio *uio,
	 struct ucred *cred, struct proc *p);

DESCRIPTION
     This vnode call may be used to retrieve a specific named extended
     attribute from a file or directory.

     Its arguments are:

     vp	   the vnode of the file or directory

     name  pointer to a null-terminated character string containing the
	   attribute name

     uio   the location of the data to be read or written

     cred  the user credentials to use in authorizing the request

     p	   the process requesting the extended attribute

     The cred pointer may be NULL to indicate that access control checks are
     not to be performed, if possible.	This cred setting might be used to
     allow the kernel to authorize extended attribute retrieval that the
     active process might not be permitted to do.

     Extended attribute semantics may vary by file system implementing the
     call.  More information on extended attributes may be found in
     extattr(9).

LOCKS
     No locks are required to call this vnode method, and any locks held on
     entry will be held on exit.

RETURN VALUES
     On success, zero will be returned, and the uio structure will be updated
     to reflect data read.  Otherwise, an appropriate error code is returned.

ERRORS
     [ENOENT]		The attribute name is not defined for this vnode

     [EACCES]		Permission denied

     [ENXIO]		The request was not valid in this file system for the
			specified vnode and attribute name.

     [ENOMEM]		Insufficient memory available to fulfill request

     [EFAULT]		The uio structure refers to an invalid userspace
			address.

     [EINVAL]		The name or uio argument is invalid.

     [EOPNOTSUPP]	The file system does not support VOP_GETEXTATTR()

SEE ALSO
     extattr(9), vnode(9), VOP_SETEXTATTR(9)

BSD			       December 23, 1999			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net