UIOMOVE(9) | Kernel Developer's Manual | UIOMOVE(9) |
The uio argument is a pointer to a struct uio as defined by <sys/uio.h>:
struct uio { struct iovec *uio_iov; int uio_iovcnt; off_t uio_offset; size_t uio_resid; enum uio_rw uio_rw; struct vmspace *uio_vmspace; };
A struct uio typically describes data in motion. Several of the fields described below reflect that expectation.
struct iovec { void *iov_base; size_t iov_len; };
The members in the struct iovec should only be initialized. These are:
The value of uio->uio_rw controls whether uiomove() copies data from buf to uio or vice versa.
The lesser of n or uio->uio_resid bytes are copied.
uiomove() changes fields of the structure pointed to by uio, such that uio->uio_resid is decremented by the amount of data moved, uio->uio_offset is incremented by the same amount, and the array of iovecs is adjusted to point that much farther into the region described. This allows multiple calls to uiomove() to easily be used to fill or drain the region of data.
April 26, 2010 | NetBSD 6.1 |