DDC(9) | Kernel Developer's Manual | DDC(9) |
The tag argument is a machine-dependent tag used to specify the I2C bus on which the DDCv2 device is located. The dest argument is a pointer to a buffer where the EDID data will be stored. The len argument is the amount of data to read into the buffer. (The buffer must be large enough.) Typically, this value will be 128, which is the size of a normal EDID data block.
Normally the EDID data block will be post-processed with the edid_parse() function.
struct edid_info info; i2c_tag_t tag; char buffer[128]; ... /* initialize i2c tag... */ ... if ((ddc_read_edid(tag, buffer, 128) == 0) && (edid_parse(buffer, &info) == 0)) edid_print(info); ...
Note that this must be called before the PCI bus is attached during autoconfiguration.
May 11, 2006 | NetBSD 6.1 |