vm_map_create man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

VM_MAP_CREATE(9)	 BSD Kernel Developer's Manual	      VM_MAP_CREATE(9)

NAME
     vm_map_create — create a new vm_map structure

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_map.h>

     vm_map_t
     vm_map_create(pmap_t pmap, vm_offset_t min, vm_offset_t max);

DESCRIPTION
     The vm_map_create() function creates and returns a new, empty map struc‐
     ture, associated with the physical map pmap, and with the upper and lower
     address bounds specified by max and min respectively.

IMPLEMENTATION NOTES
     The kernel's zone allocator is used to allocate the map.

RETURN VALUES
     The vm_map_create() function returns a pointer to the newly allocated map
     if successful.  Otherwise, it returns NULL.

SEE ALSO
     pmap(9), vm_map(9), vm_map_init(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 19, 2003				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net