usb_get_addr man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

usb_get_addr(9F)	 Kernel Functions for Drivers	      usb_get_addr(9F)

NAME
       usb_get_addr - Retrieve device USB address

SYNOPSIS
       #include <sys/usb/usba.h>

       int usb_get_addr(dev_info_t *dip);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip

	   Pointer to the device's dev_info structure.

DESCRIPTION
       The  usb_get_addr()  function  returns  the current USB bus address for
       debugging  purposes. The returned address is unique for a specific  USB
       bus,  and  may  be replicated if multiple host controller instances are
       present on the system.

RETURN VALUES
       On success: USB device address.

       On failure: returns 0. Fails if dip is NULL.

CONTEXT
       May be called from user, kernel or interrupt context.

EXAMPLES
	   int usb_addr;

	   usb_addr = usb_get_addr(dip);

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Architecture		     │PCI-based systems		   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface stability	     │Evolving			   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability		     │SUNWusb			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5), usb_pipe_open(9F)

SunOS 5.10			  Feb 9 2004		      usb_get_addr(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net