rtfree man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

RTALLOC(9)		 BSD Kernel Developer's Manual		    RTALLOC(9)

NAME
     rtalloc, rtalloc_ign, rtalloc1, rtfree — look up a route in the kernel
     routing table

SYNOPSIS
     #include <sys/types.h>
     #include <sys/socket.h>
     #include <net/route.h>

     void
     rtalloc(struct route *ro);

     void
     rtalloc_ign(struct route *ro, u_long flags);

     struct rtentry *
     rtalloc1(struct sockaddr *sa, int report, u_long flags);

     void
     rtfree(struct rt_entry *rt);

     RTFREE(struct rt_entry *rt);

     RT_LOCK(struct rt_entry *rt);

     RT_UNLOCK(struct rt_entry *rt);

     RT_ADDREF(struct rt_entry *rt);

     RT_REMREF(struct rt_entry *rt);

DESCRIPTION
     The kernel uses a radix tree structure to manage routes for the network‐
     ing subsystem.  The rtalloc() family of routines is used by protocols to
     query this structure for a route corresponding to a particular end-node
     address, and to cause certain protocol- and interface-specific actions to
     take place.

     RTF_PRCLONING flag is obsolete and thus ignored by facility.  If the
     RTF_XRESOLVE flag is set, then the RTM_RESOLVE message is sent instead on
     the route(4) socket interface, requesting that an external program
     resolve the address in question and modify the route appropriately.

     The default interface is rtalloc().  Its only argument is ro, a pointer
     to a “struct route”, which is defined as follows:

	   struct route {
		   struct sockaddr ro_dst;
		   struct rtentry *ro_rt;
	   };

     Thus, this function can only be used for address families which are
     smaller than the default “struct sockaddr”.  Before calling rtalloc() for
     the first time, callers should ensure that unused bits of the structure
     are set to zero.  On subsequent calls, rtalloc() returns without perform‐
     ing a lookup if ro->ro_rt is non-null and the RTF_UP flag is set in the
     route's rt_flags field.

     The rtalloc_ign() interface can be used when the caller does not want to
     receive the returned rtentry locked.  The ro argument is the same as
     rtalloc(), but there is additionally a flags argument, which is now only
     used to pass RTF_RNH_LOCKED indicating that the radix tree lock is
     already held.  Both rtalloc() and rtalloc_ign() functions return a
     pointer to an unlocked struct rtentry.

     The rtalloc1() function is the most general form of rtalloc() (and both
     of the other forms are implemented as calls to rtalloc1).	It does not
     use the “struct route”, and is therefore suitable for address families
     which require more space than is in a traditional “struct sockaddr”.
     Instead, it takes a “struct sockaddr *” directly as the sa argument.  The
     second argument, report, controls whether the lower layers are notified
     when a lookup fails.  The third argument, flags, is a set of flags to
     ignore, as in rtalloc_ign().  The rtalloc1() function returns a pointer
     to a locked struct rtentry.

     The rtfree() function frees a locked route entry, e.g., a previously
     allocated by rtalloc1().

     The RTFREE() macro is used to free unlocked route entries, previously
     allocated by rtalloc() or rtalloc_ign().  The RTFREE() macro decrements
     the reference count on the routing table entry (see below), and frees it
     if the reference count has reached zero.

     The preferred usage is allocating a route using rtalloc() or
     rtalloc_ign() and freeing using RTFREE().

     The RT_LOCK() macro is used to lock a routing table entry.	 The
     RT_UNLOCK() macro is used to unlock a routing table entry.

     The RT_ADDREF() macro increments the reference count on a previously
     locked route entry.  The RT_REMREF() macro decrements the reference count
     on a previously locked route entry.

RETURN VALUES
     The rtalloc(), rtalloc_ign() and rtfree() functions do not return a
     value.  The rtalloc1() function returns a pointer to a routing-table
     entry if it succeeds, otherwise a null pointer.  Lack of a route should
     in most cases be translated to the errno(2) value EHOSTUNREACH.

SEE ALSO
     route(4), rtentry(9)

HISTORY
     The rtalloc facility first appeared in 4.2BSD, although with much differ‐
     ent internals.  The rtalloc_ign() function and the flags argument to
     rtalloc1() first appeared in FreeBSD 2.0.	Routing table locking was
     introduced in FreeBSD 5.2.

AUTHORS
     This manual page was written by Garrett Wollman, as were the changes to
     implement RTF_PRCLONING and the rtalloc_ign() function and the flags
     argument to rtalloc1().

BSD			       December 11, 2008			   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net