rtentry man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

RTENTRY(9)		 BSD Kernel Developer's Manual		    RTENTRY(9)

NAME
     rtentry — structure of an entry in the kernel routing table

SYNOPSIS
     #include <sys/types.h>
     #include <sys/socket.h>
     #include <net/route.h>

DESCRIPTION
     The kernel provides a common mechanism by which all protocols can store
     and retrieve entries from a central table of routes.  Parts of this mech‐
     anism are also used to interact with user-level processes by means of a
     socket in the route(4) pseudo-protocol family.  The <net/route.h> header
     file defines the structures and manifest constants used in this facility.

     The basic structure of a route is defined by “struct rtentry”, which
     includes the following fields:

	   struct radix_node rt_nodes[2];
		   Glue used by the radix-tree routines.  These members also
		   include in their substructure the key (i.e., destination
		   address) and mask used when the route was created.  The
		   rt_key(rt) and rt_mask(rt) macros can be used to extract
		   this information (in the form of a “struct sockaddr *”)
		   given a struct rtentry *.

	   struct sockaddr *rt_gateway;
		   The “target” of the route, which can either represent a
		   destination in its own right (some protocols will put a
		   link-layer address here), or some intermediate stop on the
		   way to that destination (if the RTF_GATEWAY flag is set).

	   long rt_refcnt;
		   Route entries are reference-counted; this field indicates
		   the number of external (to the radix tree) references.  If
		   the RTF_UP flag is not present, the rtfree() function will
		   delete the route from the radix tree when the last refer‐
		   ence drops.

	   u_long rt_flags;
		   See below.

	   struct ifnet *rt_ifp;

	   struct ifaddr *rt_ifa;
		   These two fields represent the “answer”, as it were, to the
		   question posed by a route lookup; that is, they name the
		   interface and interface address to be used in sending a
		   packet to the destination or set of destinations which this
		   route represents.

	   struct sockaddr *rt_genmask;
		   When the rtalloc() family of functions performs a cloning
		   operation as requested by the RTF_CLONING or RTF_PRCLONING
		   flag, this field is used as the mask for the new route
		   which is inserted into the table.  If this field is a null
		   pointer, then a host route is generated.

	   caddr_t rt_llinfo;
		   When the RTF_LLINFO flag is set, this field contains infor‐
		   mation specific to the link layer represented by the named
		   interface address.  (It is normally managed by the
		   rt_ifa->ifa_rtrequest() routine.)  Protocols such as arp(4)
		   use this field to reference per-destination state internal
		   to that protocol.

	   struct rt_metrics rt_rmx;
		   See below.

	   struct rtentry *rt_gwroute;
		   This member is a reference to a route whose destination is
		   rt_gateway.	It is only used for RTF_GATEWAY routes.

	   struct rtentry *rt_parent;
		   A reference to the route from which this route was cloned,
		   or a null pointer if this route was not generated by
		   cloning.  See also the RTF_WASCLONED flag.

     The following flag bits are defined:
	   RTF_UP	    The route is not deleted.
	   RTF_GATEWAY	    The route points to an intermediate destination
			    and not the ultimate recipient; the rt_gateway and
			    rt_gwroute fields name that destination.
	   RTF_HOST	    This is a host route.
	   RTF_REJECT	    The destination is presently unreachable.  This
			    should result in an EHOSTUNREACH error from output
			    routines.
	   RTF_DYNAMIC	    This route was created dynamically by
			    rtredirect().
	   RTF_MODIFIED	    This route was modified by rtredirect().
	   RTF_DONE	    Used only in the route(4) protocol, indicating
			    that the request was executed.
	   RTF_CLONING	    When this route is returned as a result of a
			    lookup, automatically create a new route using
			    this one as a template and rt_genmask (if present)
			    as a mask.
	   RTF_XRESOLVE	    When this route is returned as a result of a
			    lookup, send a report on the route(4) interface
			    requesting that an external process perform reso‐
			    lution for this route.  (Used in conjunction with
			    RTF_CLONING.)
	   RTF_LLINFO	    Indicates that this route represents information
			    being managed by a link layer's adaptation layer
			    (e.g., ARP).
	   RTF_STATIC	    Indicates that this route was manually added by
			    means of the route(8) command.
	   RTF_BLACKHOLE    Requests that output sent via this route be dis‐
			    carded.
	   RTF_PROTO1
	   RTF_PROTO2
	   RTF_PROTO3	    Protocol-specific.
	   RTF_PRCLONING    Like RTF_CLONING, only managed by an entire proto‐
			    col.  (E.g., IP uses this flag to manage a per-
			    host cache integrated with the routing table, for
			    those destinations which do not have a link layer
			    performing this function.)
	   RTF_WASCLONED    Indicates that this route was generated as a
			    result of cloning requested by the RTF_CLONING or
			    RTF_PRCLONING flag.	 When set, the rt_parent field
			    indicates the route from which this one was gener‐
			    ated.
	   RTF_PINNED	    (Reserved for future use to indicate routes which
			    are not to be modified by a routing protocol.)
	   RTF_LOCAL	    Indicates that the destination of this route is an
			    address configured as belonging to this system.
	   RTF_BROADCAST    Indicates that the destination is a broadcast
			    address.
	   RTF_MULTICAST    Indicates that the destination is a multicast
			    address.

     Every route has associated with it a set of metrics, defined by struct
     rt_metrics:

	   u_long rmx_locks;
		   Flag bits indicating which metrics the kernel is not per‐
		   mitted to dynamically modify.

	   u_long rmx_mtu;
		   MTU for this path.

	   u_long rmx_hopcount;
		   Number of intermediate systems on the path to this destina‐
		   tion.

	   u_long rmx_expire;
		   The time (a la time(3)) at which this route should expire,
		   or zero if it should never expire.  It is the responsibil‐
		   ity of individual protocol suites to ensure that routes are
		   actually deleted once they expire.

	   u_long rmx_recvpipe;
		   Nominally, the bandwidth-delay product for the path from
		   the destination to this system.  In practice, this value is
		   used to set the size of the receive buffer (and thus the
		   window in sliding-window protocols like TCP).

	   u_long rmx_sendpipe;
		   As before, but in the opposite direction.

	   u_long rmx_ssthresh;
		   The slow-start threshold used in TCP congestion-avoidance.

	   u_long rmx_rtt;
		   The round-trip time to this destination, in units of
		   RTM_RTTUNIT per second.

	   u_long rmx_rttvar;
		   The average deviation of the round-type time to this desti‐
		   nation, in units of RTM_RTTUNIT per second.

	   u_long rmx_pksent;
		   A count of packets successfully sent via this route.

	   u_long rmx_filler[4];
		   Empty space available for protocol-specific information.

SEE ALSO
     route(4), route(8), rtalloc(9)

HISTORY
     The rtentry structure first appeared in 4.2BSD.  The radix-tree represen‐
     tation of the routing table and the rt_metrics structure first appeared
     in 4.3BSD-Reno.  The RTF_PRCLONING mechanism first appeared in
     FreeBSD 2.0.

AUTHORS
     This manual page was written by Garrett Wollman.

BUGS
     There are a number of historical relics remaining in this interface.  The
     rt_gateway and rmx_filler fields could be named better.

     There is some disagreement over whether it is legitimate for RTF_LLINFO
     to be set by any process other than rt_ifa->ifa_rtrequest().

BSD				October 8, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net