pgsignal man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

PSIGNAL(9)		 BSD Kernel Developer's Manual		    PSIGNAL(9)

NAME
     psignal, pgsignal, gsignal — post signal to a process or process group

SYNOPSIS
     #include <sys/types.h>
     #include <sys/signalvar.h>

     void
     psignal(struct proc *p, int signum);

     void
     pgsignal(struct pgrp *pgrp, int signum, int checkctty);

     void
     gsignal(int pgid, int signum);

DESCRIPTION
     These functions post a signal to one or more processes.  The argument
     signum common to all three functions should be in the range [1-NSIG].

     The psignal() function posts signal number signum to the process repre‐
     sented by the process structure p.	 With a few exceptions noted below,
     the target process signal disposition is updated and is marked as
     runnable, so further handling of the signal is done in the context of the
     target process after a context switch.  Note that psignal() does not by
     itself cause a context switch to happen.

     The target process is not marked as runnable in the following cases:

	   ·   The target process is sleeping uninterruptibly.	The signal
	       will be noticed when the process returns from the system call
	       or trap.

	   ·   The target process is currently ignoring the signal.

	   ·   If a stop signal is sent to a sleeping process that takes the
	       default action (see sigaction(2)), the process is stopped with‐
	       out awakening it.

	   ·   SIGCONT restarts a stopped process (or puts them back to sleep)
	       regardless of the signal action (e.g., blocked or ignored).

     If the target process is being traced psignal() behaves as if the target
     process were taking the default action for signum.	 This allows the trac‐
     ing process to be notified of the signal.

     The pgsignal() function posts signal number signum to each member of the
     process group described by pgrp.  If checkctty is non-zero, the signal
     will be posted only to processes that have a controlling terminal.
     pgsignal() is implemented by walking along the process list headed by the
     field pg_members of the process group structure pointed at by pgrp and
     calling psignal() as appropriate.	If pgrp is NULL no action is taken.

     The gsignal() function posts signal number signum to each member of the
     process group identified by the group id pgid.  gsignal() first finds the
     group structure associated with pgid, then invokes pgsignal() with the
     argument checkctty set to zero.  If pgid is zero no action is taken.

SEE ALSO
     sigaction(2), signal(9), tsleep(9)

BSD				 June 22, 1996				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net