make.cfg man page on MirBSD

Man page or keyword search:  
man Server   6113 pages
apropos Keyword Search (all sections)
Output format
MirBSD logo
[printable version]

MAKEK.CFG(5)		     BSD Reference Manual		  MAKEK.CFG(5)

NAME
     make.cfg - system-specific configuration parameters

SYNOPSIS
     .include <bsd.own.mk>

DESCRIPTION
     To get system-specific configuration parameters, <bsd.own.mk> will try to
     include the file specified by the MAKECONF variable. If MAKECONF is not
     set, or no such file exists, the system make configuration file
     /etc/make.cfg is included, if it exists. For more information on how the
     make process works, and details of the format of make files, see make(1).

     ATTENTION: This manual page might be out of date!

     <bsd.own.mk> is generally useful when building Makefiles, so that they
     use the same default owners, etc. as the rest of the tree. These files
     may define any of the variables described below. Additionally, see
     bsd.port.mk(5) for a list of variables that can be set by the ports(7)
     subsystem.

VARIABLES
     The following variables are set by <bsd.own.mk>, if they are not already
     defined. Defaults are in brackets.

     BINGRP	    Binary group. [bin]

     BINMODE	    Binary mode. [555]

     BINOWN	    Binary owner. [root]

     BSDOBJDIR	    The real path to the system 'obj' tree, so that 'make obj'
		    will work correctly. [/usr/obj]

     BSDSRCDIR	    The real path to the system sources, so that 'make obj'
		    will work correctly. [/usr/src]

     DIRMODE	    Mode for new directories. [755]

     DOCDIR	    Base path for system documentation (e.g. PSD, USD, etc.)
		    installation. [/usr/share/doc]

     DOCGRP	    Documentation group. [bin]

     DOCMODE	    Documentation mode. [${NONBINMODE}]

     DOCOWN	    Documentation owner. [root]

     INSTALL_COPY   The old usage of this flag is obsolescent, since
		    install(1) now copies by default. However, it can also be
		    used to specify that a file not be copied unless it is
		    different (via the -p option). See install(1) for details.
		    This is to be used when building an install script so that
		    the entire system can either be installed with copies, or
		    copy-if-different using a single knob. [-c]

     INSTALL_STRIP  The flag passed to the install program to cause the binary
		    to be stripped. This is to be used when building an in-
		    stall script so that the entire system can be made
		    stripped/not-stripped using a single knob. Note that
		    INSTALL_STRIP is not set if ${DEBUG} is defined. [-s]

     LIBDIR	    Base path for library installation. [/usr/lib]

     LIBGRP	    Library group. [${BINGRP}]

     LIBMODE	    Library mode. [${NONBINMODE}]

     LIBOWN	    Library owner. [${BINOWN}]

     LINTLIBDIR	    Base path for lint(1) library installation.
		    [/usr/libdata/lint]

     MANDIR	    Base path for manual installation. [/usr/share/man/cat]

     MANGRP	    Manual group. [bin]

     MANMODE	    Manual mode. [${NONBINMODE}]

     MANOWN	    Manual owner. [root]

     NONBINMODE	    Mode for non-executable files. [444]

     BSD_PREFIX	    Set to something else to affect BINDIR, MANDIR, LIBDIR
		    etc. [/usr]

ADDITIONAL VARIABLES
     Additionally, the following variables may be set by <bsd.own.mk> or in a
     make configuration file to modify the behaviour of the system build pro-
     cess (default values are in brackets along with comments, if set by
     <bsd.own.mk>):

     DEBUG		    Add -g to assembly, C compiler and linking passes.
			    Also doesn't set INSTALL_STRIP to -s per default
			    if defined.

     DEBUGLIBS		    Create libraries with -g1 debug information.

     NOLINT		    Do not build lint libraries. [yes]

     NOPIC		    Do not build PIC versions of system libraries, and
			    do not build shared libraries.

     PIPE		    If set to "-pipe", gcc(1) will be given the -pipe
			    option which can speed up compiles on machines
			    with memory to spare. Instead of using temp files,
			    gcc(1) uses pipes for the temporary data.

     SKEY		    Compile in support for S/key authentication. [yes;
			    set unconditionally]

     SKIPDIR		    A space separated list of directories to be
			    skipped during "make build".

     SUDO		    Command to run when doing "make install" portion
			    of "make build". If set to sudo, this allows one
			    to run "make build" as a user other than root (as-
			    suming sudo is set up for that user).

     SYS_INCLUDE	    Copy or symlink kernel include files into
			    /usr/include. Possible values are "symlinks" or
			    "copies" (which is the same as the variable being
			    unset).

     WARNINGS		    Adds appropriate warning flags (defined in
			    CDIAGFLAGS, e.g. -Wall...) to compiles. [no]

FILES
     /etc/make.cfg    System make configuration file.
     /usr/share/mk/*  System include make files.

SEE ALSO
     make(1), bsd.port.mk(5), ports(7)

HISTORY
     The make.cfg manual page first appeared in OpenBSD 3.4. A preset make.cfg
     file appeared first in MirOS #1, which was made modular in MirOS #5 and
     totally redesigned for MirOS #8.

MirOS BSD #10-current		March 19, 2003				     2
[top]

List of man pages available for MirBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net