device_set_ivars man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

DEVICE_GET_IVARS(9)	 BSD Kernel Developer's Manual	   DEVICE_GET_IVARS(9)

NAME
     device_get_ivars, device_set_ivars — access bus private variables

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void *
     device_get_ivars(device_t dev);

     void
     device_set_ivars(device_t dev, void *ivar);

DESCRIPTION
     The device_get_ivars() function returns the bus-specific instance vari‐
     ables of a device.

     The device_set_ivars() function sets the bus-specific instance variables
     of a device.

     Typically, only bus drivers will use these functions.  The kernel assumes
     that the bus driver will manage this memory, and no automatic memory
     allocation or deallocation happens.  Client drivers should access ivars
     through the BUS_READ_IVAR(9) interface instead.

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net