AT_EXIT(9) BSD Kernel Developer's Manual AT_EXIT(9)NAME
at_exit, rm_at_exit — ask that a function be run at exit
SYNOPSIS
#include <sys/types.h>
#include <sys/systm.h>
typedef void (exitlist_fn) (struct proc *);
int
at_exit(exitlist_fn func);
int
rm_at_exit(exitlist_fn func);
DESCRIPTION
The at_exit facility allows a kernel module to ensure that it is notified
at any process exit. The function func is called with the a pointer to
the exiting process's proc structure.
If the requirement for notification is removed, then the function
rm_at_exit() must be called with the exact func argument as the corre‐
sponding call to at_exit().
RETURN VALUES
The at_exit() function returns an errno, 0 meaning success. The
rm_at_exit() function returns the number of items removed (should be 0 or
1).
SEE ALSO_exit(2)HISTORY
The at_exit() function appeared in FreeBSD 2.2.
AUTHORS
The function was written by Julian Elischer ⟨julian@FreeBSD.org⟩.
BSD August 15, 1996 BSD