Subject: Re: [Vim-vms] VFC files truncated

From: "Jansen of Lorkeers, Richard" <[email-masked]>
Date: Thu, 27 Sep 2007 09:38:45 +0200

Hello,

I also have the same problem with rpa files. There are Carriage Return
placed.

I attached a example

Best regards,
Richard

-----Oorspronkelijk bericht-----
Van: [email-masked]
[mailto:[email-masked]]Namens Zoltan Arpadffy
Verzonden: donderdag 13 september 2007 22:14
Aan: 'Vim text editor list on OpenVMS'
Onderwerp: Re: [Vim-vms] VFC files truncated

Samuel,

I thought that this problem had been already resolved... 

Please, zip an example file on VMS and send me the zipped archive in order
to investigate closer this issue.

Thank you.

Regards,
Z

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Samuel Ferencik
Sent: den 13 september 2007 16:35
To: [email-masked]
Subject: [Vim-vms] VFC files truncated

Hello,

this topic may have been discussed before, the following discussions are 
the closest I've found:

http://www.polarhome.com/pipermail/vim-vms/2004q3/000074.html
http://lists.samba.org/archive/samba-vms/2004-July/001133.html (a 
slightly different context)

My problem is with viewing VFC files with vim on VMS (Alpha). When I 
open a file with this organisation, the file is truncated at a seemingly 
arbitrary position. There is nothing special there, no EOL, no special 
character. With native VMS editors the file is displayed correctly 
(completely).

I can provide a sample file upon request.

Thanks very much for your help.

Sam

EXE>vim --version
VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun  5 2006 17:52:20)
OpenVMS version
Included patches: 1-17
Compiled by SYSTEM@ALPHA::alpha.polarhome.com
Big version without GUI.  Features included (+) or not (-):
+arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
-clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info 
+comments
+cryptv -cscope -cursorshape +dialog_con +diff +digraphs -dnd -ebcdic
+emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path
+folding -footer -gettext -hangul_input -iconv +insert_expand +jumplist 
+keymap
  +langmap -libcall +linebreak +lispindent +listcmds +localmap +menu 
+mksession
+modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm
+mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme -netbeans_intg
-osfiletype +path_extra -perl +postscript +printer -profile -python 
+quickfix
+reltime +rightleft -ruby +scrollbind +signs +smartindent -sniff +statusline
-sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl 
+tgetent
+termresponse +textobjects +title -toolbar +user_commands +vertsplit
+virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu
+windows -writebackup -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save
    system vimrc file: "$VIM/vimrc"
      user vimrc file: "sys$login:.vimrc"
  2nd user vimrc file: "sys$login:_vimrc"
       user exrc file: "sys$login:.exrc"
   2nd user exrc file: "sys$login:_exrc"
Compilation:
cc/def=(FEAT_BIG,HAVE_CONFIG_H  )  /opt/prefix=all  /include=([.proto])
Compiler: Compaq C V6.5-001 on OpenVMS Alpha V7.3
Linking: link /exe=vim.exe *.OBJ

_______________________________________________
Vim-vms mailing list
[email-masked]
http://www.polarhome.com/mailman/listinfo/vim-vms

_______________________________________________
Vim-vms mailing list
[email-masked]
http://www.polarhome.com/mailman/listinfo/vim-vms

---

From: Zoltan Arpadffy <[email-masked]>
Date: Thu, 27 Sep 2007 10:05:57 +0200

Hello,

I was able to reproduce both errors.
fileio.c should be patched but haven't had time to find a solution yet :(

regards,
Z

> Linking: link /exe=vim.exe *.OBJ

---
WebMail, polarhome.com

---

From: Zoltan Arpadffy <[email-masked]>
Date: Thu, 27 Sep 2007 10:20:34 +0200

Hello,

no... on Richard's example Vim behaves well

RMS FILE ATTRIBUTES

         File Organization: sequential
         Record Format: stream-LF
         Record Attributes:  carriage-return
         Maximum Record Size: 0
         Longest Record: 0
         Blocks Allocated: 275, Default Extend Size: 16384
         End-of-File VBN: 160, Offset: %X'01BA'
         File Monitoring: disabled
         Global Buffer Count: 0

But Samuels VFC file is really truncatted :(

Today I have some spare time... I'll check right away.

Regards,
Z

---
WebMail, polarhome.com