Subject: Re: [Vim-vms] definition of vimruntime logical

From: "Samuel Ferencik" <[email-masked]>
Date: Wed, 3 Oct 2007 13:16:58 +0200

Hello Zoltan,

thanks for your answer. The example you provide is one of the options
that also work for me. Perhaps my description was not clear enough.
Let me try again:

alternative 0:
- use the "optional" definition suggested by the website
- login.com contains:
    $ def vim full_path:[to.the.directory]
    $ def vimruntime vim
- completion does NOT work

alternative 1:
- use full path for both logicals
- login.com contains:
    $ def vim full_path:[to.the.directory]
    $ def vimruntime full_path:[to.the.directory]
- completion does work

alternative 2 (this is what you showed in your example):
- leave vimruntime undefined
- login.com contains:
    $ def vim full_path:[to.the.directory]
- when vim is run, it creates the vimruntime logical in the lnm$job table
- completion does work

So I am not complaining about this alternative 2, but about
alternative 0, which is to use
    $ def vimruntime vim
in the login script.

Can you reproduce the problem with alternative 0?

Thanks and regards,
Sam

> Date: Tue, 2 Oct 2007 21:30:57 +0200 (CEST)
> From: Zoltan Arpadffy <[email-masked]>
> Subject: Re: [Vim-vms] definition of vimruntime logical
> To: Vim text editor list on OpenVMS <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
>
> Hello,
>
> I could not reproduce this behaviour. Here is an example:
>
> SYSTEM@alpha$ sh log vim*
>
> (LNM$PROCESS_TABLE)
>
> (LNM$JOB_8144DA80)
>
> (LNM$GROUP_000001)
>
> (LNM$SYSTEM_TABLE)
>
>    "VIM" = "DKA0:<000000.UTIL.VIM70>"
>
> (LNM$SYSCLUSTER_TABLE)
>
> (DECW$LOGICAL_NAMES)
>
> !!!!!!!!!!!! start vim
> SYSTEM@alpha$ vi
> !!!!!!!!!!!! exit vim
>
> SYSTEM@alpha$ sh log vim*
>
> (LNM$PROCESS_TABLE)
>
> (LNM$JOB_8144DA80)
>
>    "VIMRUNTIME" = "DKA0:<000000.UTIL.VIM70>"
>
> (LNM$GROUP_000001)
>
> (LNM$SYSTEM_TABLE)
>
>    "VIM" = "DKA0:<000000.UTIL.VIM70>"
>
> (LNM$SYSCLUSTER_TABLE)
>
> (DECW$LOGICAL_NAMES)
>
> ... as you can see in the JOB table appears logical VIMRUNTIME
> and :colo elf competition is woirking well.
>
> You might have some system/proces limitations to create logicals.
> If VIMRUNTIME does not exist and something prevents to be created, then we
> are simple without VIMRUNTIME enviroment in the search path (#  define
> DFLT_RUNTIMEPATH      "sys$login:vimfiles,$VIM/vimfiles,$VIMRUNTIME,$V
> IM/vimfiles/after,sys$login:vimfiles/after")
>
> Hope this help to resolve your problem
>
> Regards,
> Z
>
> On Tue, 2 Oct 2007, Samuel Ferencik wrote:
>
> > Hello,
> >
> > the vim website at polarhome gives some basic instructions on how to
> > set up the logicals VIM and VIMRUNTIME. In particular, it says that
> > assigning VIMRUNTIME is optional, and the way to do it is
> >
> > $ def VIMRUNTIME VIM
> >
> > However, this does not seem to work correctly for me. When I use this
> > definition of VIMRUNTIME, the autocomplete feature does not work with
> > some runtime stuff. For example, when I run vim, and type
> >
> > :colo elf<Tab>
> >
> > expecting "elf" to be completed to "elflord", the completion is not performed.
> >
> > What does work, however, is
> >
> > 1) defining the logical as the full path:
> > $ def VIMRUNTIME full_path:[to.the.directory]
> > (same path as used in $ def VIM)
> >
> > 2) leaving the logical undefined, as suggested by the website. (If
> > this logical does not exist Vim defines it in the process job table
> > during first run.)
> >
> > I haven't explored this any further than this, so I don't know the
> > other effects of these three alternatives. It's just a note to let you
> > know that the first alternative seems not to work...
> >
> > Thanks for the good work!
> >
> > Sam
> > _______________________________________________
> > Vim-vms mailing list
> > [email-masked]
> > http://www.polarhome.com/mailman/listinfo/vim-vms
> >
>
>
> ------------------------------
>
> _______________________________________________
> Vim-vms mailing list
> [email-masked]
> http://www.polarhome.com/mailman/listinfo/vim-vms
>
>
> End of Vim-vms Digest, Vol 21, Issue 2
> **************************************
>

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Wed, 3 Oct 2007 13:34:47 +0200

Hello Samuel,

>- completion does NOT work

You have right... VIMRUNTIME is wrong defined like this. 
Vim will never expand VIM, because it is treathen as absolute path and
not a logical. Logicals begin with $. 
VIMRUNTIME should be defined as $VIM and it will work, like below:

    $ def vimruntime $vim

I will change on the page and in the documentation as well.

Thanks.

Regards, 
Z