Subject: [Vim-vms] GTK compile

From: <[email-masked]>
Date: Fri, 31 Mar 2006 09:36:17 +0200

Hello,

Is there a deeper reason why the GTK+ version is configured with "-clientserver"?

Martin
-- 
Martin Krischik

---

From: Zoltan Arpadffy <[email-masked]>
Date: Fri, 31 Mar 2006 14:15:54 +0200 (CEST)

Martin,

no it is not a normal behaviour... it is caused by a configuration bug on 
OpenVMS platform.

I made a patch that corrects this bug.
Thank you for paying attention on that.

Hope that Bram will release this patch in 6.4 but it will be included in 
7.0 for sure.

Regards,
Z

---------------------------------------------------------------------------------
TOR_ZAY $ diff GUI_GTK_VMS.H;1 GUI_GTK_VMS.H;5
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
    80   /* VMS_END_C_PLUS_PLUS */
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
    80   extern void XTFREE(char*);
    81   /* VMS_END_C_PLUS_PLUS */
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
   126   #define XDefaultScreenOfDisplay XDEFAULTSCREENOFDISPLAY
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
   127   #define XDefaultRootWindow XDEFAULTROOTWINDOW
   128   #define XDefaultScreenOfDisplay XDEFAULTSCREENOFDISPLAY
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
   189   #define XGetWMProtocols XGETWMPROTOCOLS
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
   191   #define XGetWMIconName XGETWMICONNAME
   192   #define XGetWMProtocols XGETWMPROTOCOLS
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
   292   #define XStoreColor XSTORECOLOR
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
   295   #define XStoreBuffer XSTOREBUFFER
   296   #define XStoreColor XSTORECOLOR
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
   606   #define XtVaCreateManagedWidget XTVACREATEMANAGEDWIDGET
   607   #define XtVaCreateWidget XTVACREATEWIDGET
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
   610   #define XtVaAppCreateShell XTVAAPPCREATESHELL
   611   #define XtVaCreateManagedWidget XTVACREATEMANAGEDWIDGET
   612   #define XtVaCreatePopupShell XTVACREATEPOPUPSHELL
   613   #define XtVaCreateWidget XTVACREATEWIDGET
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1
   707   /*
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5
   713
   714   /*
************

Number of difference sections found: 6
Number of difference records found: 8

DIFFERENCES /IGNORE=()/MERGED=1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_VMS.H;5

---------------------------------------------------------------------------------
TOR_ZAY $ diff OS_VMS_CONF.H;1 OS_VMS_CONF.H;3
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_VMS_CONF.H;1
   181   #ifdef FEAT_GUI_MOTIF
   182   #define HAVE_X11
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_VMS_CONF.H;3
   181   #if defined(FEAT_GUI_MOTIF) || defined(FEAT_GUI_GTK)
   182   #define HAVE_X11
************

Number of difference sections found: 1
Number of difference records found: 1

DIFFERENCES /IGNORE=()/MERGED=1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_VMS_CONF.H;1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_VMS_CONF.H;3

---------------------------------------------------------------------------------
TOR_ZAY $ diff OS_UNIX.H;1  OS_UNIX.H;4
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_UNIX.H;1
   227   typedef struct dsc$descriptor   DESC;
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_UNIX.H;4
   227   # ifdef FEAT_GUI_GTK
   228   #  include "gui_gtk_vms.h"
   229   # endif
   230
   231   typedef struct dsc$descriptor   DESC;
************

Number of difference sections found: 1
Number of difference records found: 4

DIFFERENCES /IGNORE=()/MERGED=1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_UNIX.H;1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>OS_UNIX.H;4

---------------------------------------------------------------------------------
TOR_ZAY $ diff GUI_GTK_F.H;1 GUI_GTK_F.H;2
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_F.H;1
    12   #ifdef VMS
    13   # include "gui_gtk_vms.h"
    14   #endif
    15
    16   #include <gdk/gdk.h>
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_F.H;2
    12   #include <gdk/gdk.h>
************

Number of difference sections found: 1
Number of difference records found: 4

DIFFERENCES /IGNORE=()/MERGED=1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_F.H;1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>GUI_GTK_F.H;2

---------------------------------------------------------------------------------
ELOS,092 zay_$ diff MAKE_VMS.MMS;7 MAKE_VMS.MMS;10
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;7
     7   # This has script been tested on VMS 6.2 to 7.3 on DEC Alpha, VAX 
and IA64
     8   # with MMS and MMK
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;10
     7   # This has script been tested on VMS 6.2 to 8.2 on DEC Alpha, VAX 
and IA64
     8   # with MMS and MMK
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;7
    97   CC_DEF  = cc/decc
    98   PREFIX  = /prefix=all
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;10
    97   CC_DEF  = cc # /decc # some system requires this switch
    98                        # but when it is not required /ver might fail
    99   PREFIX  = /prefix=all
************
************
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;7
   143
   144   .IFDEF GTK
   145   GTK_DIR  = $1$DGA104:[USERS.ZAY.WORK.GTK1210.]
   146   DEFS     = "HAVE_CONFIG_H","FEAT_GUI_GTK"
******
File USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;10
   144   # NOTE: you need to set up your GTK_DIR because it is unique
   145   # on every system - logicals are not accepted
   146   .IFDEF GTK
   147   # Example:
   148   # GTK_DIR  = $202$DKB200:[USERS.ZAY.GTK1210.]
   149   GTK_DIR  = DKA0:[GTK1210.]
   150   DEFS     = "HAVE_CONFIG_H","FEAT_GUI_GTK"
************

Number of difference sections found: 3
Number of difference records found: 10

DIFFERENCES /IGNORE=()/MERGED=1-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;7-
     USRDSK:<ZAY.WORK.VIM64-8.SRC>MAKE_VMS.MMS;10

---

From: Bram Moolenaar <[email-masked]>
Date: Fri, 31 Mar 2006 16:25:39 +0200

> Hope that Bram will release this patch in 6.4 but it will be included in 

I'll include it in Vim 7.  Please try out the next snapshot, I have to
include these "diffs" by hand.

-- 
Beer & pretzels can't be served at the same time in any bar or restaurant.
		[real standing law in North Dakota, United States of America]

 /// Bram Moolenaar -- [email-masked] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://www.ICCF.nl         ///