Subject: RE: [Vim-vms] Vim: Caught deadly signal BUS

From: "Groen Norbert" <[email-masked]>
Date: Fri, 22 Oct 2004 10:29:56 +0200

Hi Jim,

;-) 
You did misunderstand my question.
It compiled well, I've got enough memory (I hope so, but I'm not a sysadmin), think about 2Gb.
The problems arise at runtime as you can see. It searches for files in "sys$login:[.vimfiles.doc]", but the only file that's in my homedirectory is my ".vimrc".

Norbert.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jim Agnew -
> Department of Neurosurgery, VCU Medical Center
> Sent: donderdag 21 oktober 2004 20:57
> To: Vim text editor list on OpenVMS
> Subject: Re: [Vim-vms] Vim: Caught deadly signal BUS
> 
> 
> Hello Groen!!!
> 
> first, make sure your decc is up to revision, read the vms 
> readme in the 
> vim distribution.  You'll need plenty of ram, my ole mvax 
> 3900 only has 
> 64, and is not enough.  These people here on this list is 
> top-notch and 
> helpfull...
> 
> Jim Agnew
> 
> Groen Norbert wrote:
> 
> > Hi,
> > 
> > I installed vim on vms, but I get a dump when I try ":help":
> > Vim: Caught deadly signal BUS                               
>                                                              
> > Vim: Finished.
> > 
> > In order to find where it goes wrong, I compiled a debug 
> version myself and look for yourself:
> > 
> > DBG> g
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-W-UNAOPNSRC, unable to open source file 
> SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.SRC.SRC]OS_UNIX.C;1
> > -RMS-E-FNF, file not found
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
> > 	Displaying source in a caller of the current routine
> > %DEBUG-I-EXITSTATUS, is '%SYSTEM-F-ACCVIO, access 
> violation, reason mask=00, virtual address=0000000000000000, 
> PC=00680018B281F120, PS=00680E04'
> > 
> > 
> > HMM...
> > 
> > I searched where it went wrong and noticed that it was this call:
> > 
> > cnt = 
> decc$to_vms(decc$translate_vms(vms_fixfilename(path)), 
> vms_wproc, 1, 0);
> > 
> >  vms_fixfilename(path) returns 
> > 
> > DBG> exa /asciz *buf
> > *OS_VMS\vms_fixfilename\buf:    "sys$login:[.vimfiles.doc]tags-??"
> > 
> > I don't know why it looks over there?
> > 
> > ==== My system 
> ==============================================================
> ==========
> > $ ws "''f$getsyi("ARCH_NAME") , ''f$getsyi("VERSION")"
> > Alpha , V7.2-1H1
> > 
> > $ sh log  vim*
> > (LNM$PROCESS_TABLE)
> >   "VIM" = "SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]"
> > 
> > $ sh sym vim*
> >   VI*M == "mcr VIM:VIM.EXE"
> > 
> > $ vi "--version"
> > VIM - Vi IMproved 6.3 (2004 June 7, compiled Oct 21 2004 18:47:44)
> > OpenVMS version
> > Included patches: 1-15
> > Compiled by SMS_NGROEN@ASD056::asd056.INDIGO.LOCAL
> > Normal version without GUI.  Features included (+) or not (-):
> > -arabic +autocmd -balloon_eval -browse +builtin_terms 
> +byte_offset +cindent 
> > -clientserver -clipboard +cmdline_compl +cmdline_hist 
> +cmdline_info +comments 
> > +cryptv -cscope +dialog_con +diff +digraphs -dnd -ebcdic 
> -emacs_tags +eval 
> > +ex_extra +extra_search -farsi +file_in_path +find_in_path 
> +folding -footer 
> > -gettext -hangul_input -iconv +insert_expand +jumplist 
> -keymap -langmap 
> > -libcall +linebreak +lispindent +listcmds +localmap +menu 
> +mksession 
> > +modify_fname +mouse -mouseshape -mouse_dec -mouse_gpm 
> -mouse_jsbterm 
> > -mouse_netterm +mouse_xterm -multi_byte +multi_lang 
> -netbeans_intg -osfiletype 
> > +path_extra -perl +postscript +printer -python +quickfix 
> -rightleft -ruby 
> > +scrollbind -signs +smartindent -sniff +statusline 
> -sun_workshop +syntax 
> > +tag_binary +tag_old_static -tag_any_white -tcl +tgetent 
> +termresponse 
> > +textobjects +title -toolbar +user_commands +vertsplit 
> +virtualedit +visual 
> > +visualextra +viminfo +vreplace +wildignore +wildmenu 
> +windows -writebackup 
> > -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save 
> >    system vimrc file: "$VIM/vimrc"
> >      user vimrc file: "sys$login:.vimrc"
> >  2nd user vimrc file: "sys$login:_vimrc"
> >       user exrc file: "sys$login:.exrc"
> >   2nd user exrc file: "sys$login:_exrc"
> > Compilation: 
> > cc/def=(FEAT_NORMAL,HAVE_CONFIG_H  )  /opt/prefix=all  
> /include=([.proto])
> > Compiler: Compaq C V6.2-008 on OpenVMS Alpha V7.2-1H1
> > Linking: link /exe=vim.exe *.OBJ               
> > 
> ==============================================================
> ===============
> > 
> > 
> > Can someone explain what is going wrong?
> > 
> > 
> > Norbert Groen.
> > 
> > _______________________________________________
> > Vim-vms mailing list
> > [email-masked]
> > http://www.polarhome.com/mailman/listinfo/vim-vms
> > 
> > 
> 
> -- 
> "Let me drop everything to work on YOUR problem..."
> _______________________________________________
> Vim-vms mailing list
> [email-masked]
> http://www.polarhome.com/mailman/listinfo/vim-vms
>

---

From: Coen Engelbarts <[email-masked]>
Date: Fri, 22 Oct 2004 11:21:29 +0200

> Vim: Caught deadly signal BUS

Hi Norbert

Your crash looks exactly like a crash I wrote about in january this year.
I get the same crash when I try ":n \[.syntax]<CTRL-D> "
That was vim 6.2.106 on OpenVMS V7.2-1.

I never found a solution for the crash, but it might help you to know that vim crashes/crashed while expanding filenames on VMS, in particular: while expanding directory names.
I suspect that your vim is looking for files, expands filenames, and then crashes.
However, your mail did not hint at why vim tried to open os_unix.c

Can you post (confirm) exactly how you encountered this problem?
Is ":help" the _exact_ command that you type?
Can you reproduce the problem without running any .vimrc files, i.e. when you start vim with "vim -U NONE"?

The file "sys$login:[.vimfiles.doc]tags-??" looks like the help index, i.e. the tags file that vim uses to find help texts.
However, I would expect that file to be in "VIM:[000000.DOC]tags.", not in your home directory. (unless vim6.3 has moved it)

Perhaps there is something wrong with your configuration of the help files.
Are your help files present?
Are they in "VIM:[000000.DOC]"?

Hope this helps,

Coen

---

From: "Groen Norbert" <[email-masked]>
Date: Fri, 22 Oct 2004 11:53:29 +0200

Coen,

> I never found a solution for the crash, but it might help you 
> to know that vim crashes/crashed while expanding filenames on 
> VMS, in particular: while expanding directory names.

Yes that's what it looks like.

> However, your mail did not hint at why vim tried to open os_unix.c

No, I don't know why either. I did a very quick debug session because I'm on a tight scedule with a project.

> Is ":help" the _exact_ command that you type?

Yes only ":help"

> Can you reproduce the problem without running any .vimrc 
> files, i.e. when you start vim with "vim -U NONE"?
> 

I can reproduce it easy enough.

> The file "sys$login:[.vimfiles.doc]tags-??" looks like the 
> help index, i.e. the tags file that vim uses to find help texts.
> However, I would expect that file to be in 
> "VIM:[000000.DOC]tags.", not in your home directory. (unless 
> vim6.3 has moved it)
> 

No, definitely not there!
The sysadmins don't want to install vim because everybody uses lse or tpu editor.
I'm on a big system with some kind of 50 developers. on about the same amount of applications. 
I have to put it in my own directories.
I suppose that [000000] works more or less like windows win32 bithole?

> Hope this helps,

It doesn't, but thanks anyhow.

Norbert.

---

From: Coen Engelbarts <[email-masked]>
Date: Fri, 22 Oct 2004 12:26:31 +0200

> I suppose that [000000] works more or less like windows win32 bithole?

I think I was not quite clear enough.

With "VIM:[000000.DOC]" I mean "The subdirectory [.DOC] in the Vim install directory"
where "the vim install directory" is whatever your logical "vim:" points to.
In Unix terms that would be "$VIM/doc", or on windows "$VIM\doc".

>   "VIM" = "SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]"

So:
Do you have the help files and a file "tags." in the directory
 "SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63.DOC]" ?

If your sysadmin won't install vim for you, then I assume that you installed vim in SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]" yourself.
If you can do that, you can also install the help files there.

I think that we want to find out why vim looks in "sys$login:[.vimfiles.doc]".
Yes, vim has a problem with expanding file names, but I don't think you should see that problem if you just type ":help".

If I understand you correctly:
- you installed the pre-compiled vim-binary from polarhome.com, and that crashed
- you only compiled a debug-version yourself to analyse the crash.
right?

I haven't installed vim 6.3 yet, so I don't know if the new pre-compiled binary has a problem.
At the moment I can only say that it does indeed have help files and a tags.-file in the subdirectory [.vim63.doc]

Coen

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Fri, 22 Oct 2004 12:50:03 +0200

hi,

sorry for late response, but I just arrived from three weeks vacation :)

Regardless, Vim should not produce such crash if help files are not in place (it should be a simple file not found type of error).

I would recommend to download vim-63-alpha.zip from http://www.polarhome.com/vim/ 
Try to install (unzip) it wherever you have rights - your home for example.

Define VIM logical and symbols

$ define vim RF10:[UTIL.VIM]                           ! vim main directory. 
$ vi*m  :== mcr VIM:VIM.EXE                            ! vi starts vim in chr. mode. 
$ gv*im :== spawn/nowait mcr VIM:VIM.EXE -g   		 ! gvi starts vim in GUI mode. 

Try to use Vim.

If this does not work than there must be some major problem that needs deeper investigation.
Please let me know what happened.

Regards, 
Z

---

From: "Groen Norbert" <[email-masked]>
Date: Fri, 22 Oct 2004 13:23:44 +0200

Coen:
[Sorry for the cutting]

> In Unix terms that would be "$VIM/doc", or on windows "$VIM\doc".

OK, I've got 
Directory SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]

DOC.DIR;1                            7  21-OCT-2004 18:51:35.10     

> Yes, vim has a problem with expanding file names, but I don't 
> think you should see that problem if you just type ":help".
> 

Correct.

> - you only compiled a debug-version yourself to analyse the crash.

Correct.

Norbert.

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Fri, 22 Oct 2004 13:45:24 +0200

hi,

> "sys$login:[.vimfiles.doc]".

Vim looks up most probable places in order to find runtime files. vimfiles is one of the standard locations

>> polarhome.com, and that crashed

Have you installed deployment ready version or you combined yourself binaries and runtime files?

Regards, 
Z

---

From: "Groen Norbert" <[email-masked]>
Date: Fri, 22 Oct 2004 13:51:36 +0200

> sorry for late response, but I just arrived from three weeks 

Just in Time.
> 
> Regardless, Vim should not produce such crash if help files 
> are not in place (it should be a simple file not found type of error).
>

Done that, but just to asure you and me, I've done that again.
With the same result ;-(
 
> Please let me know what happened.

Just once again:

Downloaded "vim-63-alpha.zip" from http://www.polarhome.com/vim/.
Unzipped in "SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM]".
Then typed:
$ Define VIM SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]
$ vi*m:== mcr vim:vim.exe
$ vim
:help
Vim: Caught deadly signal BUS                                                                                            
Vim: Finished.

Nothing more.

Bye,

Norbert.

---

From: "Groen Norbert" <[email-masked]>
Date: Fri, 22 Oct 2004 13:55:03 +0200

Zoltan:

> Vim looks up most probable places in order to find runtime 
> files. vimfiles is one of the standard locations

Yes, but how can I tell him where to look? If I know that, I think the problem is solved. (apart from some documenting ;-)
 
> yourself binaries and runtime files?

Tried everything.
See my last reaction.

Norbert.