Subject: [Vim-vms] Vim: Caught deadly signal BUS

From: "Groen Norbert" <[email-masked]>
Date: Thu, 21 Oct 2004 19:40:29 +0200

Hi,

I installed vim on vms, but I get a dump when I try ":help":
Vim: Caught deadly signal BUS                                                                                            
Vim: Finished.

In order to find where it goes wrong, I compiled a debug version myself and look for yourself:

DBG> g
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-W-UNAOPNSRC, unable to open source file SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.SRC.SRC]OS_UNIX.C;1
-RMS-E-FNF, file not found
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC 
	Displaying source in a caller of the current routine
%DEBUG-I-EXITSTATUS, is '%SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual address=0000000000000000, PC=00680018B281F120, PS=00680E04'

HMM...

I searched where it went wrong and noticed that it was this call:

cnt = decc$to_vms(decc$translate_vms(vms_fixfilename(path)), vms_wproc, 1, 0);

 vms_fixfilename(path) returns 

DBG> exa /asciz *buf
*OS_VMS\vms_fixfilename\buf:    "sys$login:[.vimfiles.doc]tags-??"

I don't know why it looks over there?

==== My system ========================================================================
$ ws "''f$getsyi("ARCH_NAME") , ''f$getsyi("VERSION")"
Alpha , V7.2-1H1

$ sh log  vim*
(LNM$PROCESS_TABLE)
  "VIM" = "SMS_DSK:[DEVSMS.USR.ALGEMEEN.VIM.VIM63]"

$ sh sym vim*
  VI*M == "mcr VIM:VIM.EXE"

$ vi "--version"
VIM - Vi IMproved 6.3 (2004 June 7, compiled Oct 21 2004 18:47:44)
OpenVMS version
Included patches: 1-15
Compiled by SMS_NGROEN@ASD056::asd056.INDIGO.LOCAL
Normal version without GUI.  Features included (+) or not (-):
-arabic +autocmd -balloon_eval -browse +builtin_terms +byte_offset +cindent 
-clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments 
+cryptv -cscope +dialog_con +diff +digraphs -dnd -ebcdic -emacs_tags +eval 
+ex_extra +extra_search -farsi +file_in_path +find_in_path +folding -footer 
-gettext -hangul_input -iconv +insert_expand +jumplist -keymap -langmap 
-libcall +linebreak +lispindent +listcmds +localmap +menu +mksession 
+modify_fname +mouse -mouseshape -mouse_dec -mouse_gpm -mouse_jsbterm 
-mouse_netterm +mouse_xterm -multi_byte +multi_lang -netbeans_intg -osfiletype 
+path_extra -perl +postscript +printer -python +quickfix -rightleft -ruby 
+scrollbind -signs +smartindent -sniff +statusline -sun_workshop +syntax 
+tag_binary +tag_old_static -tag_any_white -tcl +tgetent +termresponse 
+textobjects +title -toolbar +user_commands +vertsplit +virtualedit +visual 
+visualextra +viminfo +vreplace +wildignore +wildmenu +windows -writebackup 
-X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save 
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "sys$login:.vimrc"
 2nd user vimrc file: "sys$login:_vimrc"
      user exrc file: "sys$login:.exrc"
  2nd user exrc file: "sys$login:_exrc"
Compilation: 
cc/def=(FEAT_NORMAL,HAVE_CONFIG_H  )  /opt/prefix=all  /include=([.proto])
Compiler: Compaq C V6.2-008 on OpenVMS Alpha V7.2-1H1
Linking: link /exe=vim.exe *.OBJ               
=============================================================================

Can someone explain what is going wrong?

Norbert Groen.

---

From: "Jim Agnew - Department of Neurosurgery, VCU Medical Center" <[email-masked]>
Date: Thu, 21 Oct 2004 14:57:27 -0400

Hello Groen!!!

first, make sure your decc is up to revision, read the vms readme in the 
vim distribution.  You'll need plenty of ram, my ole mvax 3900 only has 
64, and is not enough.  These people here on this list is top-notch and 
helpfull...

Jim Agnew

Groen Norbert wrote:

> _______________________________________________
> Vim-vms mailing list
> [email-masked]
> http://www.polarhome.com/mailman/listinfo/vim-vms
> 
> 

-- 
"Let me drop everything to work on YOUR problem..."