Subject: RE: [Vim-vms] Vim: Caught deadly signal BUS

From: Coen Engelbarts <[email-masked]>
Date: Fri, 22 Oct 2004 16:45:34 +0200

Norbert Groen wrote on Friday, October 22, 2004 1:55 PM:

>> Have you installed deployment ready version or you combined
>> yourself binaries and runtime files?
>> 
> 
> Tried everything.
> See my last reaction.

Norbert, Zoltan,

I think I just reproduced Norbert's vim problem on my VMS system.

I just downloaded http://www.polarhome.com/vim/files/vim-63-alpha.zip
I unzipped it on "my" OpenVMS V7.2-1  AlphaServer ES40
I re-defined my VIM logical to the new VIM63 directory
I started vim (No file argument, no GUI)
I typed ":help"
Crash Boom Bang:

Vim: Caught deadly signal BUS
Vim: Finished.

I tried 2 different unzip commands:
   UNZIP VIM-63-ALPHA.ZIP;1
   UNZIP "-V" "-X" VIM-63-ALPHA.ZIP;1
Both give the same result.

I have never had this problem with previous binaries from polarhome.com.
I haven't upgraded vim in a while, the last one I downloaded was:

    vim --version
    VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Oct  3 2003 12:09:41)
    OpenVMS version
    Included patches: 1-106
    Compiled by ZAY@TOR::tor.essnet.se

I think it's fairly safe to say that the problem is with the binary, not with Norbert's way of installing it.
Zoltan, can you please check the zip file, and perhaps even block it for download for the moment?

Unfortunately, I don't have time to investigate right now, maybe next week.

Hope this helps,

Coen
-- 
DISCLAIMER: any disclaimer below this line was added by the company mail server, not me. ;-)

---

From: "Zoltan Arpadffy" <[email-masked]>
Date: Sat, 23 Oct 2004 17:52:00 +0200

Hi,

>I think it's fairly safe to say that the problem is with the binary,
not 
>with Norbert's way of installing it.

I do use that binary myself without any problem... but I will
investigate and try to release new binaries during this weekend.

>Zoltan, can you please check the zip file, and perhaps even block it
for >download for the moment?

I will do that...
I apologise for any inconvenience.

Regards, 
Z