Subject: Re: [Vim-vms] Vim-vms Digest, Vol 21, Issue 3

From: "Samuel Ferencik" <[email-masked]>
Date: Wed, 21 Nov 2007 09:57:26 +0100

Hello Zoltan,

following our October discussion about how to define the VIMRUNTIME
logical, I changed the definition in my VMS login script to:
    $ def VIMRUNTIME $VIM
You also changed the setup instructions on Polarhome to this.

Although the previous problems have been solved (the autocomplete
feature is now working), my :help stopped working. When I enter
    :help
in vim, I get the following error:
    Sorry, help file "$VIM/doc/help.txt" not found

Maybe this is a problem with VMS paths in vim, I don't know. In any
case, one working solution is to not define the VIMRUNTIME logical,
and let vim determine its $VIMRUNTIME dynamically.

Can you reproduce this? Can it be fixed easily? If not, perhaps it
would be good to recommend not defining the logical on Polarhome.

Thanks,
Sam

> Date: Wed, 3 Oct 2007 13:34:47 +0200
> From: "Arpadffy Zoltan" <[email-masked]>
> Subject: Re: [Vim-vms] definition of vimruntime logical
> To: "Vim text editor list on OpenVMS" <[email-masked]>
> Message-ID:
>         <[email-masked]>
> Content-Type: text/plain;       charset="us-ascii"
>
> Hello Samuel,
>
> >alternative 0:
> >- use the "optional" definition suggested by the website
> >- login.com contains:
> >    $ def vim full_path:[to.the.directory]
> >    $ def vimruntime vim
> >- completion does NOT work
>
> You have right... VIMRUNTIME is wrong defined like this.
> Vim will never expand VIM, because it is treathen as absolute path and
> not a logical. Logicals begin with $.
> VIMRUNTIME should be defined as $VIM and it will work, like below:
>
>     $ def vim full_path:[to.the.directory]
>     $ def vimruntime $vim
>
> I will change on the page and in the documentation as well.
>
> Thanks.
>
> Regards,
> Z

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Wed, 21 Nov 2007 10:26:58 +0100

Samuel,

> Can you reproduce this? 
Yes, I can confirm... the bug exists

> Can it be fixed easily? 
It should not be a big issue, the problem is that $VIM is not resolved
when it is once already resolved as $VIMRUNTIME.

In general Vim can not handle defines within defines. See the
attachment:

> If not, perhaps it would be good to recommend not defining the logical
on Polarhome.

You, re right. This should be mentioned as a known issue.

The solution is to define as a full path and not as a logical.

Regards, 
Z

------------------------------------------------------------------------
-
VIMRUNTIME defined with full path or not defined (then auto detected by
Vim)

Searching for "doc/tags doc/tags-*" in
"sys$login:vimfiles,GNU_TOP:[VIM63]vimfil
es,GNU_TOP:[VIM63],GNU_TOP:[VIM63]vimfiles/after,sys$login:vimfiles/afte
r"
Searching for "sys$login:vimfiles/doc/tags"
Searching for "sys$login:vimfiles/doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags-*"
Searching for "GNU_TOP:[VIM63]doc/tags"
Searching for "GNU_TOP:[VIM63]doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags-*"
Searching for "sys$login:vimfiles/after/doc/tags"
Searching for "sys$login:vimfiles/after/doc/tags-*"
Searching tags file GNU_TOP:[VIM63]doc/tags
Searching tags file GNU_TOP:[VIM63]doc/tags
Searching for "doc/tags doc/tags-*" in
"sys$login:vimfiles,GNU_TOP:[VIM63]vimfil
es,GNU_TOP:[VIM63],GNU_TOP:[VIM63]vimfiles/after,sys$login:vimfiles/afte
r"
Searching for "sys$login:vimfiles/doc/tags"
Searching for "sys$login:vimfiles/doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags-*"
Searching for "GNU_TOP:[VIM63]doc/tags"
Searching for "GNU_TOP:[VIM63]doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags-*"
Searching for "sys$login:vimfiles/after/doc/tags"
Searching for "sys$login:vimfiles/after/doc/tags-*"
Searching tags file GNU_TOP:[VIM63]doc/tags
"help.txt" [readonly] 213L, 7830C
Reading viminfo file "sys$login:.viminfo" marks
Searching for "scripts.vim" in
"sys$login:vimfiles,GNU_TOP:[VIM63]vimfiles,GNU_T
OP:[VIM63],GNU_TOP:[VIM63]vimfiles/after,sys$login:vimfiles/after"
Searching for "sys$login:vimfiles/scripts.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/scripts.vim"
Searching for "GNU_TOP:[VIM63]scripts.vim"
line 0: sourcing "GNU_TOP:[VIM63]scripts.vim"
finished sourcing GNU_TOP:[VIM63]scripts.vim
continuing in BufRead Auto commands for "*"
Searching for "GNU_TOP:[VIM63]vimfiles/after/scripts.vim"
Searching for "sys$login:vimfiles/after/scripts.vim"
Searching for "syntax/help.vim syntax/help/*.vim" in
"sys$login:vimfiles,GNU_TOP
:[VIM63]vimfiles,GNU_TOP:[VIM63],GNU_TOP:[VIM63]vimfiles/after,sys$login
:vimfile
s/after"
Searching for "sys$login:vimfiles/syntax/help.vim"
Searching for "sys$login:vimfiles/syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/syntax/help.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]syntax/help.vim"
line 22: sourcing "GNU_TOP:[VIM63]syntax/help.vim"
finished sourcing GNU_TOP:[VIM63]syntax/help.vim
continuing in function <SNR>3_SynSet
Searching for "GNU_TOP:[VIM63]syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/after/syntax/help.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/after/syntax/help/*.vim"
Searching for "sys$login:vimfiles/after/syntax/help.vim"
Searching for "sys$login:vimfiles/after/syntax/help/*.vim"
Searching for "syntax/help.vim syntax/help/*.vim" in
"sys$login:vimfiles,GNU_TOP
:[VIM63]vimfiles,GNU_TOP:[VIM63],GNU_TOP:[VIM63]vimfiles/after,sys$login
:vimfile
s/after"
Searching for "sys$login:vimfiles/syntax/help.vim"
Searching for "sys$login:vimfiles/syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/syntax/help.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]syntax/help.vim"
line 22: sourcing "GNU_TOP:[VIM63]syntax/help.vim"
finished sourcing GNU_TOP:[VIM63]syntax/help.vim
continuing in function <SNR>3_SynSet
Searching for "GNU_TOP:[VIM63]syntax/help/*.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/after/syntax/help.vim"
Searching for "GNU_TOP:[VIM63]vimfiles/after/syntax/help/*.vim"
Searching for "sys$login:vimfiles/after/syntax/help.vim"
Searching for "sys$login:vimfiles/after/syntax/help/*.vim"

------------------------------------------------------------------------
----------------

VIMRUNTIME defined as a logical $VIM

Searching for "doc/tags doc/tags-*" in
"sys$login:vimfiles,GNU_TOP:[VIM63]vimfil
es,$VIM,GNU_TOP:[VIM63]vimfiles/after,sys$login:vimfiles/after"
Searching for "sys$login:vimfiles/doc/tags"
Searching for "sys$login:vimfiles/doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/doc/tags-*"
Searching for "$VIM/doc/tags"
Searching for "$VIM/doc/tags-*"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags"
Searching for "GNU_TOP:[VIM63]vimfiles/after/doc/tags-*"
Searching for "sys$login:vimfiles/after/doc/tags"
Searching for "sys$login:vimfiles/after/doc/tags-*"
Searching tags file GNU_TOP:[VIM63]doc/tags
Sorry, help file "$VIM/doc/help.txt" not found