Subject: [Vim-vms] VFC files

From: Samuel Ferencik <[email-masked]>
Date: Wed, 21 Apr 2010 10:18:38 +0200

Hi Zoltan,

in the past, I reported a problem reading VFC files in vim (these
being truncated). This is currently tracked as a "major" problem.

I have a backup of the VFC file with which I first spotted the error.
However, now it seems to be opened correctly. Is it possible this has
been fixed?

You also managed to reproduce it in the past. Could you, please, give
it a try now?

Thanks,
Sam
---

VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Jan 13 2009 12:38:00)
OpenVMS version - Alpha
Included patches: 1-79

---

From: Arpadffy Zoltan <[email-masked]>
Date: Wed, 21 Apr 2010 10:33:01 +0200

Hello,

I have made a fix for reading and writing VFC files few years ago.
I am glad that it works.

Regards,
Z

-----Original Message-----
From: Samuel Ferencik [mailto:[email-masked]]
Sent: den 21 april 2010 10:19
To: [email-masked]
Subject: [Vim-vms] VFC files

Hi Zoltan,

Thanks,
Sam
---

VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Jan 13 2009 12:38:00)
OpenVMS version - Alpha
Included patches: 1-79
_______________________________________________
Vim-vms mailing list
[email-masked]
http://www.polarhome.com/mailman/listinfo/vim-vms

---

From: Samuel Ferencik <[email-masked]>
Date: Wed, 21 Apr 2010 10:55:37 +0200

OK, thanks.
I will do some more testing, and will let you know (within a month) to
confirm that I can't reproduce it.
Sam

---

From: Samuel Ferencik <[email-masked]>
Date: Tue, 27 Jul 2010 15:08:01 +0200

Hi Zoltan,

a bit late, but I would like to confirm (as the original submitter) that I
cannot reproduce this problem (VFC files truncated) anymore.

I guess you can now remove this from the list of known bugs at
http://www.polarhome.com/vim/
   Major: VFC organized RMS files are in some cases truncated during
reading. (there are indications that this is a C RTL bug)

Thanks for the fix.

Best regards,
Sam

---
:version
VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Jan 12 2009 16:05:50)
OpenVMS version - IA64
Included patches: 1-79
Compiled by ZAY@TITAN2::TITAN2.SCIGAMES.AT
Huge version without GUI.  Features included (+) or not (-):
+arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
-clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info
+comments +cryptv -cscope -cursorshape +dialog_con +diff +digraphs -dnd
-ebcdic +emacs_tags
+eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +float
+folding -footer -gettext -hangul_input -iconv +insert_expand +jumplist
+keymap +langmap -libcall +linebreak +lispindent +listcmds +localmap +menu
+mksession
+modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm
+mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte +multi_lang
-mzscheme -netbeans_intg -osfiletype +path_extra -perl +postscript +printer
+profile -python
+quickfix +reltime +rightleft -ruby +scrollbind +signs +smartindent -sniff
+statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white
-tcl +tgetent +termresponse +textobjects +title -toolbar +user_commands
+vertsplit
+virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu
+windows -writebackup -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save
  system vimrc file: "$VIM/vimrc"
    user vimrc file: "sys$login:.vimrc"
2nd user vimrc file: "sys$login:_vimrc"
     user exrc file: "sys$login:.exrc"
 2nd user exrc file: "sys$login:_exrc"
Compilation: cc/def=(FEAT_HUGE,HAVE_CONFIG_H  )  /opt/prefix=all
 /include=([.proto])
Compiler: HP C V7.2-001 on OpenVMS IA64 V8.3
Linking: link /exe=vim.exe *.OBJ

---

From: Arpadffy Zoltan <[email-masked]>
Date: Tue, 27 Jul 2010 15:26:47 +0200

Hello Sam,

Thank you for the confirmation. I am glad that it works.
You are welcome.

Regards,
Z

________________________________
From: Samuel Ferencik [mailto:[email-masked]]
Sent: den 27 juli 2010 15:08
To: Vim text editor list on OpenVMS
Subject: Re: [Vim-vms] VFC files

Hi Zoltan,

a bit late, but I would like to confirm (as the original submitter) that I cannot reproduce this problem (VFC files truncated) anymore.

I guess you can now remove this from the list of known bugs at http://www.polarhome.com/vim/
   Major: VFC organized RMS files are in some cases truncated during reading. (there are indications that this is a C RTL bug)

Thanks for the fix.

Best regards,
Sam

---
:version
VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Jan 12 2009 16:05:50)
OpenVMS version - IA64
Included patches: 1-79
Compiled by ZAY@TITAN2::TITAN2.SCIGAMES.AT<http://TITAN2.SCIGAMES.AT>
Huge version without GUI.  Features included (+) or not (-):
+arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv -cscope -cursorshape +dialog_con +diff +digraphs -dnd -ebcdic +emacs_tags
+eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer -gettext -hangul_input -iconv +insert_expand +jumplist +keymap +langmap -libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
+modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte +multi_lang -mzscheme -netbeans_intg -osfiletype +path_extra -perl +postscript +printer +profile -python
+quickfix +reltime +rightleft -ruby +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl +tgetent +termresponse +textobjects +title -toolbar +user_commands +vertsplit
+virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows -writebackup -X11 -xfontset -xim -xsmp -xterm_clipboard -xterm_save
  system vimrc file: "$VIM/vimrc"
    user vimrc file: "sys$login:.vimrc"
2nd user vimrc file: "sys$login:_vimrc"
     user exrc file: "sys$login:.exrc"
 2nd user exrc file: "sys$login:_exrc"
Compilation: cc/def=(FEAT_HUGE,HAVE_CONFIG_H  )  /opt/prefix=all  /include=([.proto])
Compiler: HP C V7.2-001 on OpenVMS IA64 V8.3
Linking: link /exe=vim.exe *.OBJ

On Wed, Apr 21, 2010 at 10:55, Samuel Ferencik <[email-masked]<mailto:[email-masked]>> wrote:
> <[email-masked]<mailto:[email-masked]>> wrote:
>> Hello,
>>
>> From: Samuel Ferencik [mailto:[email-masked]<mailto:[email-masked]>]
>> To: [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>