Subject: Re: [Vim-vms] VFC files truncated

From: "Jansen of Lorkeers, Richard" <[email-masked]>
Date: Thu, 27 Sep 2007 11:50:02 +0200

I found the cause, we edited some files with SED, the result is that the
file contains at different points the Carriage Returns

-----Oorspronkelijk bericht-----
Van: [email-masked]
[mailto:[email-masked]]Namens Zoltan Arpadffy
Verzonden: donderdag 27 september 2007 10:21
Aan: [email-masked]
Onderwerp: Re: [Vim-vms] VFC files truncated

Hello,

no... on Richard's example Vim behaves well

RMS FILE ATTRIBUTES

         File Organization: sequential
         Record Format: stream-LF
         Record Attributes:  carriage-return
         Maximum Record Size: 0
         Longest Record: 0
         Blocks Allocated: 275, Default Extend Size: 16384
         End-of-File VBN: 160, Offset: %X'01BA'
         File Monitoring: disabled
         Global Buffer Count: 0

But Samuels VFC file is really truncatted :(

Today I have some spare time... I'll check right away.

Regards,
Z

Quoting "Jansen of Lorkeers, Richard" <[email-masked]>:

> Hello,
>
> I also have the same problem with rpa files. There are Carriage Return
> placed.
>
> I attached a example
>
> Best regards,
> Richard
>
> -----Oorspronkelijk bericht-----
> Van: [email-masked]
> [mailto:[email-masked]]Namens Zoltan Arpadffy
> Verzonden: donderdag 13 september 2007 22:14
> Aan: 'Vim text editor list on OpenVMS'
> Onderwerp: Re: [Vim-vms] VFC files truncated
>
>
> Samuel,
>
> I thought that this problem had been already resolved...
>
> Please, zip an example file on VMS and send me the zipped archive in order
> to investigate closer this issue.
>
> Thank you.
>
> Regards,
> Z
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Samuel Ferencik
> Sent: den 13 september 2007 16:35
> To: [email-masked]
> Subject: [Vim-vms] VFC files truncated
>
> Hello,
>
> this topic may have been discussed before, the following discussions are
> the closest I've found:
>
> http://www.polarhome.com/pipermail/vim-vms/2004q3/000074.html
> http://lists.samba.org/archive/samba-vms/2004-July/001133.html (a
> slightly different context)
>
> My problem is with viewing VFC files with vim on VMS (Alpha). When I
> open a file with this organisation, the file is truncated at a seemingly
> arbitrary position. There is nothing special there, no EOL, no special
> character. With native VMS editors the file is displayed correctly
> (completely).
>
> I can provide a sample file upon request.
>
> Thanks very much for your help.
>
> Sam

---
WebMail, polarhome.com
_______________________________________________
Vim-vms mailing list
[email-masked]
http://www.polarhome.com/mailman/listinfo/vim-vms

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Mon, 1 Oct 2007 09:45:10 +0200

Hello,

I have investigated the issue and seems that the HP C RTL has a bug.
I will report this to HP to get some help.

In fact open()-read() functions do not read the VFC files to the EOF in
some cases.

SYS$QIO functions behave well - but I do not plan to replace all low
level file access functions to QIO.

It helps if open() gets a "ctx=bin" parameter, but this is not the
solution either, because in that case Vim does not understand really the
line delimiters.

It is interesting that Emacs behaves on the very same way as Vim -
because Emacs uses as well Unix portable open/read functions.
 
What can we do?

1. mark "VFC files truncated" as a known major issue
2. ask HP for a work-a-round and/or report C RTL error
3. test "ctx=bin" behaviour with other FAB/RFM/RAT combinations with Vim
4. correct binary writing to file for VFC files (done, patch not issued
yet)
5. investigate more about Vim EOL delimiter functionality.

As I can see now, there are two possibilities to solve the problem:
I) use 2) and 4)
II) use 3), 4), 5)

I will post updates here regarding this topic.

Regards, 
Z