Subject: RE: [Vim-vms] Vim 6.3-86 + 7.0aa preview

From: "David C. Lyon" <[email-masked]>
Date: Wed, 28 Sep 2005 08:13:44 -0700

I'm running VMS 7.3-1/Alpha and just downloaded the
vim-63-exe-axp-term.zip distribution 6.3-86. Unpacked and tested. Vim on
VMS has been working great except for the following issue (all recent
versions I've tried)

  vim *.txt

causes the CPU to max and the command to hang.

  Vim:== disk:[dir]VIM.EXE -U /disk/dir/vimrc.

Also, if in VIM and I do:

  :e <tab>

I get ... and then VIM hangs.

If it matters, the volume status:

  Volume Status:  ODS-5, subject to mount verification, protected
subsystems
      enabled, file high-water marking, write-through caching enabled,
hard
      links enabled.

Any help would be appreciated.  Thanks!

---------------------------------------------------------------------
David C. Lyon, California State Polytechnic University, Pomona      
Instructional and Information Tech.  http://david.c.lyon.home.att.net
---------------------------------------------------------------------

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Zoltan Arpadffy
> Sent: Tuesday, September 27, 2005 2:52 AM
> To: [email-masked]
> Subject: [Vim-vms] Vim 6.3-86 + 7.0aa preview
> 
> hello,
> 
> I have built and tested Vim 6.3-86 on VAX, Alpha and IA64.
> Packages with executables are available at:
> - http://www.polarhome.com/vim/
> - ftp://ftp.polarhome.com/pub/vim/
> 
> Major change VMS related change is that all function keys are enabled,
> that allows usage of useful utilities as SelectBuf (default on F3)
etc.
> 
> Also you can find a 7.0aa preview (just Alpha executables) at
> http://www.polarhome.com/vim/files/developers/
> 
> Regards,
> Z
> _______________________________________________
> Vim-vms mailing list
> [email-masked]
> http://www.polarhome.com/mailman/listinfo/vim-vms

---

From: "Zoltan Arpadffy" <[email-masked]>
Date: Wed, 28 Sep 2005 23:51:04 +0200

David,

What version have you used earlier (that did not hang)?

... I was able to reproduce the problem even with 6.3-31 when I started vim
on in a directory that contains more than 300 files (about 250 *.com) with
command vim *.com

I could not reproduce the :e <tab> like problem.

It might be some buffer size related bug... needs more investigation.

Regards, 
Z                 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of David C. Lyon
Sent: den 28 september 2005 17:14
To: Vim text editor list on OpenVMS
Subject: RE: [Vim-vms] Vim 6.3-86 + 7.0aa preview

  vim *.txt

  :e <tab>