Subject: RE: [Vim-vms] RE: Help with VIM on VMS/DSM

From: Coen Engelbarts <[email-masked]>
Date: Fri, 19 Apr 2002 13:56:39 +0200

Hi all,

I found this mail a bit confusing because of the multiple quotes, and I hope
I understand it correctly:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 19 April 2002 09:53
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Vim-vms] RE: Help with VIM on VMS/DSM

> > > Unfortunately, this problem is an issue...
> > > actually all interwindow regex related commads has this problem.
> > > Between Vim versions 5.8 and 6.0 OpenVMS specific source 
> > code had been
> > > merged with into Unix one to improve compatibility and > 
> maintenance time
> > > for OpenVMS leaving os_vms.c just a non portable part of 
> > OpenVMS code.
> > > With this solution OpenVMS get automatically all Unix > 
> features and does
> > > not need any VMS specific port for every each 
> improvement, > but it uses
> > > heavily Unix C compatibility library, that, seems to have 
> > some problems on
> > > versions 7.1 and below.

Is this about the fact that vim sometimes crashes? I.e. this problem:

> > > > > "Vim: Caught deadly signal BUS" and VMS session freezes up.

Do I understand correctly that this is caused by bugs in the regex functions
of the Unix compatibility library?

BTW: On my system, the VMS session does not really "freeze up", but the
DECTerm no longer echoes the commands that I type on the DCL prompt.
Everything else, including DCL/program output to terminal, still works.

> > > Vim does not have this behaviour on systems 7.1-2 and above.
> > > on vim-vms list it has been discussed a lot and we 
> decided > (together with
> > > Bram) to leave it as it is.
> > > So, it is a known problem, that will disappear by time as 
> > you upgrade your
> > > OpenVMS environment.

Errmm.. I have a problem with this statement. I see the crashing vim error
on both VMS systems that I use, and they have VMS versions  V7.1-2 and
V7.2-1.
Perhaps "my" systems have an older Unix compatibility library installed?
That would be great, because it would mean I can upgrade the library and get
rid of the crashes! Yay! :-)
What library(ies) are relevant, and what version(s) do I need?
Or perhaps I misunderstood the issue?

Thanks in advance,

Coen

---

From: [email-masked]
Date: Fri, 19 Apr 2002 14:22:20 +0200

hi,

> Errmm.. I have a problem with this statement. I see the > crashing vim error
> Perhaps "my" systems have an older Unix compatibility library > installed?
> That would be great, because it would mean I can upgrade the > library and get

the test clearly indicates failures on 21 and 32 systems below 7.1-2, and I could not reproduce the bug on 7.2 systems (nor alpha nor vax)

Runtime libs should come together with the VMS...

BUT if you can reproduce the bug maybe we can lok at it a bit deeper.

Regards, Z

---

From: Coen Engelbarts <[email-masked]>
Date: Fri, 19 Apr 2002 15:00:30 +0200

> the test clearly indicates failures on 21 and 32 systems 
> below 7.1-2, and I could not reproduce the bug on 7.2 systems 
> (nor alpha nor vax)

Right. Test 21 and test 32 fail on systems below 7.1-2.

> BUT if you can reproduce the bug maybe we can lok at it a bit deeper.

Well, I just did:
In sys$login, I did:
	$ gvim *.com
	                   5 files to edit

Then I do :help <valid help subject> and gvim crashes.
The terminal shows
	Vim: Caught deadly signal BUS
	Vim: Finished.
$

Now the terminal no longer echoes the commands that I enter, but DCL/program
output to terminal still works.

I see the same with terminal vim.
(It does not matter if I have syntax hilighting on or off, in vim or gvim)

This is version:
	VIM - Vi IMproved 6.1a BETA (2002 Feb 24, compiled Mar  4 2002
11:27:24)
	OpenVMS version
	Included patches: 1-23
	Compiled by ZAY@PLUTO::pluto.essnet.se
	(etc.)

Generally, the crash seems to occur when (g)vim changes to a new syntax,
e.g. the help syntax, or switching between DCL and C files.

It's been on my to-do/wish-list for a while to compile vim myself and try to
get some more debugging-info. We have a nice Insight compiler here that does
run-time checking for out-of-bounds memory access and stuff like that. I'm
really more familiar with Unix than with VMS, so I don't know how to get
more info than this.
I REALLY would love to see this bug solved. Vim is not supposed to crash,
and VMS programs are not supposed to crash. It has kept me from installing
vim 6.x as the public/standard vim on these sytems.

Can you clarify the "unix-libary" story a bit, please? What library is this
exactly?
The only candidate for a "unix" or 'posix" library that I have found is
SYS$SHARE:CDE$UNIX_ROUTINES.EXE, and on the V7.1-2 system it has version:
	Version:  "V1.0"
	Linktime: 22-JAN-1998 13:37:16.77
	Platform: AXP

Thanks in advance.

Coen

---

From: [email-masked]
Date: Fri, 19 Apr 2002 15:28:34 +0200

hi,

> 	Vim: Caught deadly signal BUS

It is really an odd behaviour, because I just tried and it worked perfect on OpenVMS Alpha V7.2-1, with GUI and term as well.

BUT if you can locate the bug somehow with your nice debugger, I would be the first person who will send you a bottle of wine from Sweden :-)

Have a nice weekend,
regards, Z