Subject: [Vim-vms] FW: Vim 7! - OpenVMS

From: "Zoltan Arpadffy" <[email-masked]>
Date: Wed, 10 May 2006 15:37:17 +0200

Mike,

I (and the Vim community on VMS) would really appreciate if you would be
able to give some hints in order to solve printing problems on OpenVMS.

Thank you in advance.

Regards, 
Z

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: den 10 maj 2006 15:24
To: Zoltan Arpadffy
Subject: RE: Vim 7! - OpenVMS

Zoltan -

> Thank you for releasing Vim7. It works stable and very well on VMS - 
> but I have recently found a strange problem, that I have not noticed
> earlier:
> 
> I get error: E620: Unable to convert to print encoding "dec-mcs" while

> printing.
> 
> Wonder, if you can point out where should I search the problem.
> Please note that printing worked perfect earlier (in 6.4)

Multi-byte printing was added.  Check your 'printencoding' option.

Mike Williams made this, you could try contacting him.  It's also good
that he knows about problems that users run into.

- Bram

---

From: "Zoltan Arpadffy" <[email-masked]>
Date: Fri, 12 May 2006 10:18:18 +0200

Mike,

Thank you very much for fast and competent help.

>A workaround for a user is to set encoding to the same as printencoding
so a null 
>conversion is used. 

Fast solution was to define:

:set penc="" 

>After tha it would be good to add dec-cms to enc_canon_table to
indicate it is an 
>8-bit encoding so no attempt is made to do a conversion.

I tried to add, but it does not helped really.

Regardess, it works now... 
Probably this should be the default option for VMS.

Regards, 
Z