Subject: [Vim-vms] Vim: Caught deadly signal BUS - Solution?

From: "Zoltan Arpadffy" <[email-masked]>
Date: Sun, 24 Oct 2004 00:32:02 +0200

Hi,
 
You can find below a quick and dirty patch that corrects the problem.
 
Seems either decc$to_vms() or decc$translate_vms() does not like "??"
wildcards.
I'll try to find some permanent solution for this problem, because both
mch_expandpath() and mch_expand_wildcards() are based on these
functions. 
 
Regards, 
Z
 
SYSTEM@alpha$ diff_ tag.c
************
File DKA0:<WORK.VIM63-31.SRC>TAG.C;2
 2385                       "doc/tags doc/tags-*"
 2386   #else
******
File DKA0:<WORK.VIM63-31.SRC>TAG.C;1
 2385                       "doc/tags doc/tags-??"
 2386   #else
************
 
Number of difference sections found: 1
Number of difference records found: 1
 
DIFFERENCES /IGNORE=()/MERGED=1-
    DKA0:<WORK.VIM63-31.SRC>TAG.C;2-
    DKA0:<WORK.VIM63-31.SRC>TAG.C;1

---

From: "Groen Norbert" <[email-masked]>
Date: Mon, 25 Oct 2004 10:34:06 +0200

Hi,
 
That seems to do the trick indeed. Could have tought of that before;-)
Wildcards ??? do'nt work under vms indeed, in dcl %%% is used, tried that, but that didn't work either.
I do'nt understand where the decc$ procs come from. 
Is it somewhere in a decc library?
 
Thanks for so far!
 
Norbert. 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Zoltan Arpadffy
Sent: zondag 24 oktober 2004 0:32
To: [email-masked]
Subject: [Vim-vms] Vim: Caught deadly signal BUS - Solution?

Hi,

Seems either decc$to_vms() or decc$translate_vms() does not like "??" wildcards.
I'll try to find some permanent solution for this problem, because both mch_expandpath() and mch_expand_wildcards() are based on these functions. 
 
Regards, 
Z

---

From: "Arpadffy Zoltan" <[email-masked]>
Date: Mon, 25 Oct 2004 11:53:13 +0200

Norbert,
 
> Is it somewhere in a decc library

It must be, because I run on OpenVMS V7.2-2  on daily basis and could not reproduce the problem, but at home (polarhome.com) system came out immediately. 
Also it might be already fixed with some ECO patch. Boxes in the company are always updated not as my home system :(
 
I will try to release some general patch (with binaries) later today.
 
Regards, 
Z