Subject: [Vim-vms] RE: Help with VIM on VMS/DSM

From: [email-masked]
Date: Fri, 19 Apr 2002 9:53:19 +0200

hi,

2. vim does create temp files at $TMP as tmp:vimXXXXXXX.txt (example: VIMP649D30.TXT;1), and it usually deletes later on... but sys$login should be user for .rc files, viminfo, viminfo-tmp, tags etc...

3. unfortunately I've never worked with DSM, but hopefully somebody from the vim-vms list did, and can help you.

Regards, Z

> -----Original Message-----
> From: MIME :[email-masked] > Sent: Thursday, April 18, 2002 5:58 PM
> To: Arpadffy Zoltan
> Subject: RE: Help with VIM on VMS/DSM
> > > Zoltan,
> > Thanks for answering back on my email; I love vi(m) and would like to
> replace it totally on our VMS/DSM system here.  Do you know > the answer to
> Problems 2 and 3 (I am
> assu============================================================
> -(PROBLEM (2)) My Tmp files are not being created in Tmp but > in my login
> directory.
> -(PROBLEM (2): QUESTION) Should they not be forming in the > Tmp directory as
> I point to in my login file above?
> > > ============================================================
> -(PROBLEM (3))  I cannot figure out how to put Vi in the DSM > environment to
> get it to be my default editor in DSM as it already now is in > VMS.  (We use
> DSM as our interpreter to create Mumps code, and it would be > nice to have
> this working in DSM also.  (VI is working fairly well already > in VMS, and it
> would be a much better editor than EDT that is currently > running in DSM.
> (EDT is very primitive compared to VI and is the default > editor that comes
> with DSM)).
> -(PROBLEM (3): QUESTION)  How do I import the Vi(m) editor > into the DSM
> environment.  (DSM runs in VMS as the an interpreter and all > routines in DSM
> are in ASCII, as compilation occurs behind the scenes as code > is written).
> ming that your answer was for Problem 1?)
> > ============================================================
> -(PROBLEM (2)) My Tmp files are not being created in Tmp but > in my login
> directory.
> -(PROBLEM (2): QUESTION) Should they not be forming in the > Tmp directory as
> I point to in my login file above?
> > > ============================================================
> -(PROBLEM (3))  I cannot figure out how to put Vi in the DSM > environment to
> get it to be my default editor in DSM as it already now is in > VMS.  (We use
> DSM as our interpreter to create Mumps code, and it would be > nice to have
> this working in DSM also.  (VI is working fairly well already > in VMS, and it
> would be a much better editor than EDT that is currently > running in DSM.
> (EDT is very primitive compared to VI and is the default > editor that comes
> with DSM)).
> -(PROBLEM (3): QUESTION)  How do I import the Vi(m) editor > into the DSM
> environment.  (DSM runs in VMS as the an interpreter and all > routines in DSM
> are in ASCII, as compilation occurs behind the scenes as code > is written).
> > > Thanks again for your help,
> Mario
> ====
> > > > -----Original Message-----
> > From:	[email-masked] > [SMTP:[email-masked]]
> > Sent:	Thursday, April 18, 2002 12:45 AM
> > To:	[email-masked]
> > Cc:	[email-masked]
> > Subject:	RE: Help with VIM on VMS/DSM
> >
> > hi,
> >
> > Unfortunately, this problem is an issue...
> > actually all interwindow regex related commads has this problem.
> > Between Vim versions 5.8 and 6.0 OpenVMS specific source > code had been
> > merged with into Unix one to improve compatibility and > maintenance time
> > for OpenVMS leaving os_vms.c just a non portable part of > OpenVMS code.
> > With this solution OpenVMS get automatically all Unix > features and does
> > not need any VMS specific port for every each improvement, > but it uses
> > heavily Unix C compatibility library, that, seems to have > some problems on
> > versions 7.1 and below.
> > Vim does not have this behaviour on systems 7.1-2 and above.
> > on vim-vms list it has been discussed a lot and we decided > (together with
> > Bram) to leave it as it is.
> > So, it is a known problem, that will disappear by time as > you upgrade your
> > OpenVMS environment.
> >
> > Regards, Z
> >
> > > -----Original Message-----
> > > From: Kopányi Sándor > Sent: Thursday, April 18, 2002 9:23 AM
> > > To: Arpadffy Zoltan
> > > Subject: FW: Help with VIM on VMS/DSM
> > > > > Szia,
> > > > Van vmi otleted?
> > > > udvS.
> > > > > -----Original Message-----
> > > > From: MIME :[email-masked] > > Sent: Monday, > April 15, 2002
> > 8:02 PM
> > > > To: Kopányi Sándor
> > > > Subject: RE: Help with VIM on VMS/DSM
> > > > > > > > Sandor,
> > > > > > I put the runtine files onto our VMS system and > when I am in > >
> > "vi" on a file
> > > > (such as "vi filename") and do "help sort" (or any > other > > help), I
> > get the
> > > > following error:
> > > > "Vim: Caught deadly signal BUS" and VMS session freezes up.
> > > > > > But if I just do: "vi" with no file name listed, > then I can > > do
> > "help sort"
> > > > (or any other help feature) and it works OK.
> > > > I downloaded the zip file from polarfax.com: > vim-61-alpha.zip > >
> > 3772 KB
> > > > > > I set up the following directory structure for VIM:
> > > > > > Directory TUSER$:[MARIO.VIM]
> > > > CTAGS.EXE;1              530   7-FEB-2002 16:36:48.30  > >
> > (RWED,RWED,RE,RE)
> > > > GVIMRC.;2                  4   3-APR-2002 17:33:00.72  >
> > (RWED,RWED,RE,)
> > > > GVIMRC.;1                  4   3-APR-2002 17:32:50.58  >
> > (RWED,RWED,RE,)
> > > > MMS_VIM.EXE;1              8   7-FEB-2002 16:36:48.61  > >
> > (RWED,RWED,RE,RE)
> > > > TMP.DIR;1                  1  13-MAR-2002 15:47:59.40  > >
> > (RWE,RWED,RWE,RWE)
> > > > VIM.EXE;1               4197   7-FEB-2002 16:36:48.64  > >
> > (RWED,RWED,RE,RE)  **
> > > > VIMRC.;1                   5   3-APR-2002 17:33:28.53  >
> > (RWED,RWED,RE,)
> > > > VIMRUNTIME.DIR;1           1  13-MAR-2002 15:49:17.76  > >
> > (RWE,RWED,RWE,RWE)
> > > >   Directory TUSER$:[MARIO.VIM.VIMRUNTIME]
> > > > ---DOC.DIR;1                  8  13-MAR-2002 15:49:56.26  > >
> > (RWE,RWED,RE,RE)
> > > > ---SYNTAX.DIR;1              16  13-MAR-2002 15:50:02.68  > >
> > (RWE,RWED,RE,RE)
> > > > XXD.EXE;1                 30   7-FEB-2002 16:36:50.81  > >
> > (RWED,RWED,RE,RE)
> > > > > > I have the following vim references in my login.com:
> > > > ED =="VIM"
> > > > $ define VIM TUSER$:[MARIO.VIM]
> > > > $ define TMP TUSER$:[MARIO.VIM.TMP]
> > > > $ define VIMRUNTIME TUSER$:[MARIO.VIM.VIMRUNTIME]
> > > > $ ! vi starts Vim in chr. mode
> > > > $ vi*m  :== mcr   TUSER$:[MARIO.VIM]VIM.EXE
> > > > > > Also, the Tmp files are not being created in Tmp > but in my > >
> > login directory;
> > > > should they not be forming in the Tmp directory above?
> > > > > > **(I could not use the one of size: 4930 KB from > the complete > >
> > download; I
> > > > would get an error and vi would not work)
> > > > > > -Any Ideas or is that the way the help is supposed > to work: > >
> > you can only use
> > > > help in the vi with no file name listed?
> > > > > > Thanks,
> > > > Mario
> > > > =====
> > > > > > > > > -----Original Message-----
> > > > > From:	[email-masked] [SMTP:[email-masked]]
> > > > > Sent:	Wednesday, April 03, 2002 11:53 PM
> > > > > To:	[email-masked]
> > > > > Subject:	RE: Help with VIM on VMS/DSM
> > > > > > Hi Mario,
> > > > > > > We are using Open VMS Version V7.2-1  and vim.exe > seems > > to >
> > work on
> > > > > this one.
> > > > > > The only thing I found was that the down and up > keys on > > Vim
> > work one
> > > > > > keytouch behind when I hit the keypad at the 1st > position > > of >
> > the file
> > > > > (in
> > > > > > cursor mode).
> > > > > > You can try to re-map those keys (see :map command).
> > > > > > > > Also, do you know who might know how to put > vim.exe > > into
> > the > DSM
> > > > > interpreter
> > > > > > of VMS?
> > > > > Unfortunately I have no ideea, I have never been working with
> > > > > DSM. Sorry...
> > > > > > Best regards,
> > > > > Sandor
> > > > > > > > >
> > >

---

From: David Elins <[email-masked]>
Date: Thu, 02 May 2002 20:54:19 -0400

Did you get any help on running vim from DSM. I may be able to help with 
this if you are still having trouble, let me know.

By the way, I did not like having to define a vms logical name TMP in order 
to use vim so I ended up patching vim.exe (using vim -b) to change the 
logical name to
TM_  !

David

At 09:53 AM 4/19/2002 +0200, [email-masked] wrote:
>hi,
>
>2. vim does create temp files at $TMP as tmp:vimXXXXXXX.txt (example: 
>VIMP649D30.TXT;1), and it usually deletes later on... but sys$login should 
>be user for .rc files, viminfo, viminfo-tmp, tags etc...
>
>_______________________________________________
>Vim-vms mailing list
>[email-masked]
>http://www.polarhome.com/mailman/listinfo/vim-vms