Subject: Re: [Vim-vms] VFC files truncated

From: "Jansen of Lorkeers, Richard" <[email-masked]>
Date: Thu, 27 Sep 2007 11:38:14 +0200

Right but when I open this file with another editor the file does not
compile anymore.

-----Oorspronkelijk bericht-----
Van: [email-masked]
[mailto:[email-masked]]Namens Zoltan Arpadffy
Verzonden: donderdag 27 september 2007 10:21
Aan: [email-masked]
Onderwerp: Re: [Vim-vms] VFC files truncated

Hello,

no... on Richard's example Vim behaves well

RMS FILE ATTRIBUTES

         File Organization: sequential
         Record Format: stream-LF
         Record Attributes:  carriage-return
         Maximum Record Size: 0
         Longest Record: 0
         Blocks Allocated: 275, Default Extend Size: 16384
         End-of-File VBN: 160, Offset: %X'01BA'
         File Monitoring: disabled
         Global Buffer Count: 0

But Samuels VFC file is really truncatted :(

Today I have some spare time... I'll check right away.

Regards,
Z

Quoting "Jansen of Lorkeers, Richard" <[email-masked]>:

> Hello,
>
> I also have the same problem with rpa files. There are Carriage Return
> placed.
>
> I attached a example
>
> Best regards,
> Richard
>
> -----Oorspronkelijk bericht-----
> Van: [email-masked]
> [mailto:[email-masked]]Namens Zoltan Arpadffy
> Verzonden: donderdag 13 september 2007 22:14
> Aan: 'Vim text editor list on OpenVMS'
> Onderwerp: Re: [Vim-vms] VFC files truncated
>
>
> Samuel,
>
> I thought that this problem had been already resolved...
>
> Please, zip an example file on VMS and send me the zipped archive in order
> to investigate closer this issue.
>
> Thank you.
>
> Regards,
> Z
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Samuel Ferencik
> Sent: den 13 september 2007 16:35
> To: [email-masked]
> Subject: [Vim-vms] VFC files truncated
>
> Hello,
>
> this topic may have been discussed before, the following discussions are
> the closest I've found:
>
> http://www.polarhome.com/pipermail/vim-vms/2004q3/000074.html
> http://lists.samba.org/archive/samba-vms/2004-July/001133.html (a
> slightly different context)
>
> My problem is with viewing VFC files with vim on VMS (Alpha). When I
> open a file with this organisation, the file is truncated at a seemingly
> arbitrary position. There is nothing special there, no EOL, no special
> character. With native VMS editors the file is displayed correctly
> (completely).
>
> I can provide a sample file upon request.
>
> Thanks very much for your help.
>
> Sam

---
WebMail, polarhome.com
_______________________________________________
Vim-vms mailing list
[email-masked]
http://www.polarhome.com/mailman/listinfo/vim-vms

---

From: "Jansen of Lorkeers, Richard" <[email-masked]>
Date: Thu, 27 Sep 2007 12:03:46 +0200

Hello,

A question,
a solution for our problem is that I would like to execute a commandline for
different sources to:
- start vim with a variable source name
- write the source with a different name
How can I do this with a commandfile, does anyone have suggestions.

So for instance the file has the name PP755_EP.rpa but must be named to
PP755_EP_1.rpa

( in this way the record format is change from VFC to Streamed length)

Best regards
Richard

-----Oorspronkelijk bericht-----

Hello,

RMS FILE ATTRIBUTES

Regards,
Z

---
WebMail, polarhome.com